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The same WHEA error is logged again even though no uncorrectable error has occurred on a WHEA-enabled computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is based on a Windows Hardware Error Architecture (WHEA)-enabled platform.
  • The platform has a CPU that supports Machine Check Architecture (MCA).
  • The computer is running Windows 7 or Windows Server 2008 R2.
  • An uncorrectable error occurs which causes a machine-check exception, and then causes a Stop error.
  • The computer is restarted automatically.
  • The uncorrectable error is collected by WHEA and logged in the System log.
  • You perform a soft restart on the computer.
In this scenario, the same WHEA error is logged again in the System log even though no uncorrectable error has occurred.

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Cause

The issue occurs because the IA32_MCi_STATUS machine check error status registers (MSRs) are not cleared during the soft restart.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Hal.dll6.1.7600.21079194,41629-Oct-201104:43x86
Halacpi.dll6.1.7600.21079137,07229-Oct-201104:43x86
Halmacpi.dll6.1.7600.21079194,41629-Oct-201104:43x86
Hal.dll6.1.7601.21849194,41629-Oct-201106:28x86
Halacpi.dll6.1.7601.21849137,07229-Oct-201106:28x86
Halmacpi.dll6.1.7601.21849194,41629-Oct-201106:28x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Hal.dll6.1.7600.21079263,02429-Oct-201105:45x64
Hal.dll6.1.7601.21849263,02429-Oct-201107:15x64

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Workaround

To work around this issue, you have to turn off the computer and then turn it on again.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_3a668085ddc0f128a902c6dd9e83d577_31bf3856ad364e35_6.1.7601.21849_none_2fe588b6e2ce64e2.manifest
File versionNot Applicable
File size691
Date (UTC)01-Nov-2011
Time (UTC)05:33
File nameX86_a85679fde46ea355edd9beacd07c629b_31bf3856ad364e35_6.1.7600.21079_none_2e49edca22838820.manifest
File versionNot Applicable
File size691
Date (UTC)01-Nov-2011
Time (UTC)05:33
File nameX86_microsoft-windows-hal_31bf3856ad364e35_6.1.7600.21079_none_ab979846d40fdb00.manifest
File versionNot Applicable
File size9,274
Date (UTC)29-Oct-2011
Time (UTC)05:05
File nameX86_microsoft-windows-hal_31bf3856ad364e35_6.1.7601.21849_none_ad9e8ed4d11dbcfe.manifest
File versionNot Applicable
File size9,274
Date (UTC)29-Oct-2011
Time (UTC)07:16
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_588da6e01c16ae7b8abc5e22cf38d363_31bf3856ad364e35_6.1.7600.21079_none_3e8760a1c92e27df.manifest
File versionNot Applicable
File size695
Date (UTC)01-Nov-2011
Time (UTC)05:33
File nameAmd64_cb620bde97c22c8804be6b5f15211a35_31bf3856ad364e35_6.1.7601.21849_none_3168bcae1a66dd63.manifest
File versionNot Applicable
File size695
Date (UTC)01-Nov-2011
Time (UTC)05:33
File nameAmd64_microsoft-windows-hal_31bf3856ad364e35_6.1.7600.21079_none_07b633ca8c6d4c36.manifest
File versionNot Applicable
File size7,549
Date (UTC)29-Oct-2011
Time (UTC)06:08
File nameAmd64_microsoft-windows-hal_31bf3856ad364e35_6.1.7601.21849_none_09bd2a58897b2e34.manifest
File versionNot Applicable
File size7,549
Date (UTC)29-Oct-2011
Time (UTC)08:20

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2635732
Revision : 1
Created on : 1/7/2017
Published on : 12/14/2011
Exists online : False
Views : 230