Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Issues when you try to display a large TIFF file that contains multiple pages by using Windows Photo Viewer in Windows Vista, in Windows 7, in Windows Server 2008 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Assume that you try to open a large TIFF file that contains multiple pages by using Windows Photo Viewer on a computer that is running one of the following operating systems:
  • Windows Vista
  • Windows Server 2008
  • Windows 7
  • Windows Server 2008 R2
In this situation, you may experience one of the following issues.

Issue 1

When you scroll through the pages in the TIFF file, the computer stops responding. Additionally, the available memory is exhausted. To recover from this issue, manually close Windows Photo Viewer by using Task Manager.

Issue 2

Window Photo Viewer does not open the TIFF file. Additionally, you receive the following error message:
Windows Photo Viewer can't open this picture because the file appears to be damaged, corrupted or is too large.

↑ Back to the top


Cause

These issues occur because of the way of that memory is allocated when Windows displays a TIFF file.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Photoviewer.dll6.0.6002.228052,323,45628-Feb-201214:46x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Photoviewer.dll6.0.6002.228052,924,03228-Feb-201215:44x64
Photoviewer.dll6.0.6002.228052,323,45628-Feb-201214:46x86
Windows 7 and Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Photoviewer.dll6.1.7600.210851,456,12805-Nov-201104:36x86
Photoviewer.dll6.1.7601.218551,456,12805-Nov-201104:31x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Photoviewer.dll6.1.7600.210851,727,48805-Nov-201105:30x64
Photoviewer.dll6.1.7601.218551,727,48805-Nov-201105:35x64
Photoviewer.dll6.1.7600.210851,456,12805-Nov-201104:36x86
Photoviewer.dll6.1.7601.218551,456,12805-Nov-201104:31x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size2,574
Date (UTC)28-Feb-2012
Time (UTC)17:20
PlatformNot Applicable
File nameX86_01cb586789a7df415bde9da14d8a787c_31bf3856ad364e35_6.0.6002.22805_none_d5f1fe34211df81f.manifest
File versionNot Applicable
File size699
Date (UTC)28-Feb-2012
Time (UTC)17:20
PlatformNot Applicable
File nameX86_microsoft-windows-photoviewer_31bf3856ad364e35_6.0.6002.22805_none_deb3ae5de5f79057.manifest
File versionNot Applicable
File size82,092
Date (UTC)28-Feb-2012
Time (UTC)15:04
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_95867b5c72c00f652008e3b557c434b8_31bf3856ad364e35_6.0.6002.22805_none_eea4e92c2947ba2b.manifest
File versionNot Applicable
File size1,046
Date (UTC)28-Feb-2012
Time (UTC)17:20
PlatformNot Applicable
File nameAmd64_microsoft-windows-photoviewer_31bf3856ad364e35_6.0.6002.22805_none_3ad249e19e55018d.manifest
File versionNot Applicable
File size82,142
Date (UTC)28-Feb-2012
Time (UTC)16:02
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,594
Date (UTC)28-Feb-2012
Time (UTC)17:20
PlatformNot Applicable
File nameX86_microsoft-windows-photoviewer_31bf3856ad364e35_6.0.6002.22805_none_deb3ae5de5f79057.manifest
File versionNot Applicable
File size82,092
Date (UTC)28-Feb-2012
Time (UTC)15:04
PlatformNot Applicable

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_usb.inf_31bf3856ad364e35_6.0.6002.22734_none_cd4c182324cae7eb.manifest
File versionNot Applicable
File size2,644
Date (UTC)28-Oct-2011
Time (UTC)21:25
File nameX86_usbport.inf_31bf3856ad364e35_6.0.6002.22734_none_c01610a019e635d2.manifest
File versionNot Applicable
File size6,734
Date (UTC)28-Oct-2011
Time (UTC)21:25
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_4e69293990aabd14cf3ed3b1ad5f6fe8_31bf3856ad364e35_6.1.7600.21085_none_1ecaa571eba82988.manifest
File versionNot Applicable
File size1,046
Date (UTC)05-Nov-2011
Time (UTC)14:11
File nameAmd64_77379db36965813fe63acd90c57f6ed7_31bf3856ad364e35_6.1.7601.21855_none_6791d21402c7888b.manifest
File versionNot Applicable
File size1,046
Date (UTC)05-Nov-2011
Time (UTC)14:11
File nameAmd64_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.21085_none_38bcfb4f028704a6.manifest
File versionNot Applicable
File size50,300
Date (UTC)05-Nov-2011
Time (UTC)06:01
File nameAmd64_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7601.21855_none_3ac3f1dcff94e6a4.manifest
File versionNot Applicable
File size50,300
Date (UTC)05-Nov-2011
Time (UTC)06:14
File nameX86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.21085_none_dc9e5fcb4a299370.manifest
File versionNot Applicable
File size50,296
Date (UTC)05-Nov-2011
Time (UTC)05:08
File nameX86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7601.21855_none_dea556594737756e.manifest
File versionNot Applicable
File size50,296
Date (UTC)05-Nov-2011
Time (UTC)05:05

↑ Back to the top


Keywords: kb, kbautohotfix, kbhotfixserver, kbqfe, kbfix, kbsurveynew, kbexpertisebeginner

↑ Back to the top

Article Info
Article ID : 2635500
Revision : 1
Created on : 1/7/2017
Published on : 4/11/2012
Exists online : False
Views : 248