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Outlook prompts for credentials when an Exchange Server 2010 CAS restarts


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Symptoms

Consider the following scenario:
  • A Microsoft Exchange Server 2010 server has the Client Access server (CAS) role assigned.
  • The Exchange Server 2010 CAS is a member of Client Access Array.
  • The CAS is shut down or restarted.
  • A Microsoft Outlook client tries to connect to the CAS through a server that has Network Load Balancing (NLB) configured. The Outlook client has connected to the CAS before.
In this scenario, the RPC service on the CAS shuts down any existing connections, and sends a reset notification to clients. When a client tries to create a new connection, the new connection fails because the CAS is not accepting new connections. Therefore, the client prompts the user for credentials.

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Cause

This issue occurs because services on the CAS are stopped when it is shut down or restarted. However, the network load balancer does not recognize that the services are offline.

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Resolution

To prevent this issue, do not let the CAS accept new connections from the load balancer before the CAS is shut down or restarted. For example, issue a drainstop command to the server in Network Load Balancing Manager.

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Workaround

To work around this issue, cancel the credential request, and then restart the Outlook client. After all clients have disconnected from the CAS, shut down or restart the server.

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References

For information about an issue that can occur when you try to connect to an Exchange mailbox by using Microsoft Outlook 2007, click the following article number to go to the article in the Microsoft Knowledge Base:

927612 You are repeatedly prompted to enter your credentials when you try to connect to an Exchange mailbox by using Outlook 2007
For information about an issue in which you are repeatedly prompted for a password in Outlook 2007, click the followng article number to go to the article in the Microsoft Knowledge Base:

956531 Outlook 2007 prompts you repeatedly for a password under certain network conditions
For information about an issue in which you are prompted for credentials in Outlook 2007 after an Exchange CAS is restarted, click the following article number to go to the article in the Microsoft Knowledge Base:

2540817 Outlook 2007 prompts for credentials after Exchange CAS is restarted
For more information about load balancing in Exchange Server 2010, go to the following TechNet website:For general information about load balancing, go to the following TechNet website:

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Keywords: KB2634633, kbprb, kbexpertiseinter, kbtshoot, kbsurveynew

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Article Info
Article ID : 2634633
Revision : 1
Created on : 7/25/2013
Published on : 7/25/2013
Exists online : False
Views : 396