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The Number of Items in Retry Table counter displays an incorrect value that causes SCOM alerts in an Exchange Server 2010 SP1 organization


View products that this article applies to.

Symptoms

In a Microsoft Exchange Server 2010 Service Pack 1 (SP1) organization that is monitored by a System Center Operations Manager (SCOM) server, you receive the following SCOM alerts for Exchange Server 2010 Mailbox servers unexpectedly: 
Alert: Number of items in retry table has been more than 30000 for Number minutes.
ObjectName: MSExchange Search Indices
CounterName: Number of Items in Retry table
Additionally, if you restart the Microsoft Exchange Search Indexer service on the Exchange Server 2010 server, the Number of Items in Retry Table counter value shows a different value to the value before the service restarts.

Note This issue typically occurs after you move mailboxes in the organization.

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Cause

This issue occurs because the Search Indexer service does not update the cache for the Number of Items in Retry Table counter. Therefore, the counter displays an incorrect value and causes SCOM alerts.

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Resolution

To resolve this issue, install the following update rollup:
2645995 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 2

Registry key information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
After you apply the update, to configure the cache time-out value, following these steps: 
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then select the following registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\ExSearch
  3. On the Edit menu, point to New, and then click DWORD (32-bit) value.
  4. Type NumberOfRetryItemsTimeoutInMinutes, and then press ENTER.
  5. Right-click NumberOfRetryItemsTimeoutInMinutes, and then click Modify.
  6. In the Value data box, type CustomValue, and then click OK.
  7. Exit Registry Editor.


Note By default, the time-out value is set to 5 minutes.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, visit the following Microsoft website:

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Keywords: kbqfe, kbfix, kbexpertiseinter, kbsurveynew, kb

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Article Info
Article ID : 2633044
Revision : 1
Created on : 1/7/2017
Published on : 2/13/2012
Exists online : False
Views : 337