Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Test Management Warehouse Sync job times out in Visual Studio TFS 2010 SP1


Symptoms

When you use Microsoft Visual Studio Team Foundation Server (TFS) 2010 Service Pack 1 (SP1), the Test Management Warehouse Sync job times out intermittently. Additionally, the data warehouse is not generated as expected.

In this situation, the following exception is triggered:
TF221122: An error occurred running job Test Management Warehouse Sync for team project collection or Team Foundation server DefaultCollection. ---> System.InvalidOperationException: This SqlTransaction has completed; it is no longer usable. at System.Data.SqlClient.SqlTransaction.ZombieCheck() at System.Data.SqlClient.SqlTransaction.Rollback() at Microsoft.TeamFoundation.Framework.Server.TeamFoundationSqlResourceComponent.Dispose() at Microsoft.TeamFoundation.Warehouse.WarehouseDataAccessComponent.Dispose() at Microsoft.TeamFoundation.TestManagement.Warehouse.TeamTestWarehouseAdapter.DeleteTcmObjects(Boolean deleteResults) at Microsoft.TeamFoundation.TestManagement.Warehouse.TeamTestWarehouseAdapter.ProcessDeletes() at Microsoft.TeamFoundation.TestManagement.Warehouse.TeamTestWarehouseAdapter.MakeDataChanges() at Microsoft.TeamFoundation.Warehouse.WarehouseSyncJobExtension`1.MakeDataChanges(TeamFoundationRequestContext requestContext, TeamFoundationJobDefinition jobDefinition, String& resultMessage) at Microsoft.TeamFoundation.Warehouse.WarehouseSyncJobExtension`1.RunInternal(TeamFoundationRequestContext requestContext, TeamFoundationJobDefinition jobDefinition, DateTime queueTime, String& resultMessage) at Microsoft.TeamFoundation.Warehouse.WarehouseJobExtension.Run(TeamFoundationRequestContext requestContext, TeamFoundationJobDefinition jobDefinition, DateTime queueTime, String& resultMessage)

↑ Back to the top


Cause

This issue occurs because of a design error in the Test Management Warehouse Sync job. This error can manifest when the job processes a large amount of deleted test data.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Visual Studio TFS 2010 SP1 installed.

Restart requirement

If the affected files are being used when you apply this hotfix, you may have to restart the computer. We recommend that you exit all instances of Visual Studio before you apply this hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For all supported versions of Visual Studio TFS 2010 SP1

File nameFile versionFile sizeDateTimePlatform
Microsoft.teamfoundation.admin.dll10.0.40219.36324,725,81616-Nov-1113:19x86
Microsoft.teamfoundation.build.server.plugins.dll10.0.40219.36346,42416-Nov-1113:19x86
Microsoft.teamfoundation.framework.server.dll10.0.40219.3631,100,62416-Nov-1113:19x86
Microsoft.teamfoundation.server.deploy.tfcollection.dll10.0.40219.363562,53616-Nov-1113:19x86
Microsoft.teamfoundation.server.dll10.0.40219.363222,00816-Nov-1113:19x86
Microsoft.teamfoundation.testmanagement.adapter.dll10.0.40219.36393,02416-Nov-1113:19x86
Microsoft.teamfoundation.versioncontrol.server.dll10.0.40219.363615,77616-Nov-1113:19x86
Microsoft.teamfoundation.versioncontrol.server.plugins.dll10.0.40219.36326,99216-Nov-1113:19x86
Microsoft.teamfoundation.versioncontrol.server.proxy.dll10.0.40219.36390,47216-Nov-1113:19x86
Microsoft.teamfoundation.warehouse.dll10.0.40219.3633,524,41616-Nov-1113:19x86
Microsoft.teamfoundation.workitemtracking.server.dataaccesslayer.dll10.0.40219.363590,20816-Nov-1113:19x86
Microsoft.teamfoundation.workitemtracking.server.dataservices.dll10.0.40219.363143,74416-Nov-1113:19x86

↑ Back to the top


More Information

For more information about the components of the data warehouse for Team Foundation, visit the following MSDN website:For more information about how to manually process the data warehouse and the Microsoft SQL Server Analysis Services cube for TFS, visit the following MSDN website:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbhotfixdev, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2629068
Revision : 1
Created on : 1/7/2017
Published on : 3/27/2012
Exists online : False
Views : 85