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A Windows Server 2008 R2-based RRAS server stops responding if a PPTP connection from a portable device is torn down


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Routing and Remote Access Service (RRAS) server that is running Windows Server 2008 R2.
  • A portable device (such as a mobile phone or a Tablet PC) establishes a Point-to-Point Tunneling Protocol (PPTP) connection to the RRAS server.
  • The device is not running a Windows operating system.
  • The device tears down the PPTP connection without sending a Call-Clear-Request control message. This behavior is not compliant with the Request for Comments (RFC) standard for PPTP. For more information about the RFC standard for PPTP, visit the following IETF website:
In this scenario, the RRAS server may not respond to new incoming PPTP connection requests.

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Cause

This issue occurs because the RRAS server leaves the associated TCP session in a CLOSED_WAIT state if the portable device does not send a Call-Clear-Request control message. Therefore, if the portable device continues to make and disconnect PPTP connections, the RRAS server eventually runs out of the TCP ports are used for PPTP connections.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Raspptp.sys6.1.7601.21829111,10430-Sep-201106:14x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Raspptp.sys6.1.7601.21829243,71230-Sep-201104:45IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_8f06a251c234a30839564ad8202fd1ad_31bf3856ad364e35_6.1.7601.21829_none_347403a6e6d63b03.manifest
File versionNot Applicable
File size707
Date (UTC)30-Sep-2011
Time (UTC)16:46
File nameAmd64_microsoft-windows-rasbase-raspptp_31bf3856ad364e35_6.1.7601.21829_none_f898f66517979c19.manifest
File versionNot Applicable
File size2,901
Date (UTC)30-Sep-2011
Time (UTC)09:13
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_5f4d24eccefff492c21f7986c263fcd5_31bf3856ad364e35_6.1.7601.21829_none_44035a75bffdbe40.manifest
File versionNot Applicable
File size705
Date (UTC)30-Sep-2011
Time (UTC)16:46
File nameIa64_microsoft-windows-rasbase-raspptp_31bf3856ad364e35_6.1.7601.21829_none_9c7bfed75f3833df.manifest
File versionNot Applicable
File size2,899
Date (UTC)30-Sep-2011
Time (UTC)09:06

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, KB2625737

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Article Info
Article ID : 2625737
Revision : 1
Created on : 11/9/2011
Published on : 11/9/2011
Exists online : False
Views : 426