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FIX: Threat Management Gateway 2010 administrators may be unable to generate reports


View products that this article applies to.

Symptoms

Microsoft Forefront Threat Management Gateway 2010 (TMG) administrators may be unable to generate reports for User Activity, reports for Site Activity, or summary reports if report generation takes longer than 1 minute. In this case, the task may fail with the following error:
Forefront TMG Error

The operation failed.

Error: 0xc00403ec

The Microsoft Forefront TMG Control service could not be accessed. The error occurred on object 'Reports' of class 'Reports Configuration' in the scope of array 'Array name'
This issue occurs primarily when you run User Activity and Site Activity reports, because they typically take a longer time to run. However, this issue may also occur when you run daily, weekly, or monthly summary reports.

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Cause

This issue occurs because the remote procedure call (RPC) connection to the TMG report server times out after 1 minute. This causes report generation to fail.

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Resolution

To resolve this problem, install the service pack that is described in the following Microsoft Knowledge Base article:
2649961 Rollup 1 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

By default, this enables a time-out of 5 minutes. If this time is not enough then it may necessary to increase the time-out for both the RPC connection by using the RPC_REPORT_TIMEOUT_MULTIPLIER value and the report server time-out with RS_SOAP_CLIENT_TIMEOUT_IN_MILLISECONDS.

For example, to increase the time-out to 20 minutes, configure the following registry keys.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\REPORTING
  3. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
  4. Type RPC_REPORT_TIMEOUT_MULTIPLIER, and then press Enter.
  5. On the Edit menu, click Modify.
  6. Select Decimal in the Base section.
  7. Type 20, and then click OK.

    Note This is a multiplier of the UIRpcTimeout value. By default, the value of this registry key is 60,000 milliseconds, and this registry key controls the default UI RPC time-out. We do not advise you to change the UIRpcTimeout value, because changing this value may cause the TMG MMC to become unresponsive for a long duration.
  8. Exit Registry Editor.
Note The RPC_REPORT_TIMEOUT_MULTIPLIER time-out multiplier value must be set on any computer from which you want to run the report. For example, this value can be set on other TMG nodes, on an EMS server, or on management clients. The multiplier value will take effect when the TMG MMC is restarted.

You may also have to increase the time-out for report generation to the same value as the RPC time-out or to a larger value. You must do this on the TMG report server. To identify the TMG report server, follow these steps:
  1. Start the Threat Management Gateway 2010 Microsoft Management Console (MMC).
  2. Expand the Arrays node, and then expand the array that you want to check.
  3. Select Logs & Reports, and then click the Reporting tab.
  4. In the Tasks pane, click Configure Reporting Settings.
  5. Select the Report Server tab. The dialog box will show you the server on which SQL Reporting Services is running.
For example, to increase the time-out for the report generation to 20 minutes, configure the following registry keys: Follow these steps, and then quit Registry Editor:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\REPORTING
  3. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
  4. Type RS_SOAP_CLIENT_TIMEOUT_IN_MILLISECONDS, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Select Decimal in the Base section.
  7. Type 1200000, and then click OK.
  8. Exit Registry Editor.

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Workaround

To work around this problem, increase the UIRpcTimeout value on the computer that you ran the report from. 

Important We do not recommend that you increase the UIRpcTimeout value, because doing this may cause the TMG MMC to become unresponsive for a long time. This registry value controls the default UI RPC time-out value and has a default value of 60,000 milliseconds.

For example, to increase the UIRpcTimeout value to 5 minutes, create a registry key named UIRpcTimeout (REG_DWORD) under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fpc\Logging, and then assign it a value of 300000 decimal (5*60000). After you install the update, you can revert the UIRpcTimeout value to 60000 decimal.

The UIRpcTimeout value will take effect when the TMG MMC is restarted.

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References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbqfe, kbfix, kbexpertiseinter, kbsurveynew, kb

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Article Info
Article ID : 2624178
Revision : 1
Created on : 1/7/2017
Published on : 1/11/2012
Exists online : False
Views : 327