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Error Message "Error Locating Object Handler" When Downloading a .pdf File


View products that this article applies to.

This article was previously published under Q262213

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Symptoms

When you attempt to download a Portable Document Format (.pdf) file, you may receive the following error message:
Error Locating Object Handler: There is no viewer available for the type of object you are trying to open. The following information is available about this object:

Address of object: http://Web address

Content Type: text/html

Possible location of viewer: Microsoft ActiveX Gallery

Do you want to go to this location to download a viewer for this type of object?
If you click Yes, your browser is redirected to the following Microsoft Web site:

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Cause

This behavior can occur when there is a dependency with a Netscape Navigator plug-in (Nppdf32.dll) for Adobe Acrobat Reader.

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Resolution

To resolve this behavior, perform the following steps:
  1. Install the latest Adobe Acrobat Reader software from the following Adobe Web site:
  2. Install the latest Netscape Communicator software from the following Netscape Web site:
  3. Verify that the Nppdf32.dll file is in the following folders:

    C:\Program Files\Adobe\Acrobat 4.0\Reader\Browser
    -and-
    C:\Program Files\Netscape\Communicator\Program\Plugins
If the Netscape software is not installed on your computer, copy the Nppdf32.dll file from the C:\Program Files\Adobe\Acrobat 4.0\Reader\Browser folder to the C:\Program Files\Internet Explorer\Plugins folder.

For more information about how to copy files, click Start, click Help, click the Index tab, type copying, and then double-click the Copying Files, Folders, Files Or Folders, or To copy a file or folder topic.

If you use Adobe Acrobat Reader with Internet Explorer 5.5 or higher and you receive the preceding error when you attempt to open a PDF file, perform the following steps:
  1. Close Internet Explorer 5.5.
  2. Click Start, click Programs, and open Adobe Acrobat Reader 4.0. or 4.5.
  3. Click File, click Preferences, and then click General.
  4. Click to clear the Web Browser Integration check box.
  5. Close Adobe Acrobat Reader.
  6. Restart Internet Explorer 5.5 and return to the Web page again. This time you are prompted to open the PDF file.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Workaround

To work around this behavior, follow these steps:
  1. In Adobe Acrobat 4.0, from the File Menu, select Preferences.
  2. Select General.
  3. Under Options, click to clear the Open Cross-doc Links in Same Window check box, and then close the dialog box.

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Keywords: KB262213, kbprb, kberrmsg, kb3rdparty

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Article Info
Article ID : 262213
Revision : 6
Created on : 1/27/2007
Published on : 1/27/2007
Exists online : False
Views : 399