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Error message in the Security Synchronization Utility when you synchronize a rule: "System.Runtime.InteropServices.COMException"


Symptoms

When you synchronize rules from Business Portal - MBF to Web Services GP in the Security Synchronization Utility, you receive the error:
Error -  System.Runtime.InteropServices.COMException

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Cause

Entries already exist in the Dynamics Security Console for the role in the rule set.

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Resolution

1. If SQL Server was selected for the Dynamics Security Data Store during the Web Services install, make a backup of the Web Services security store database in the SQL Server Management Studio.

2. On the Web Server where Web Services in installed, click Start, point to Administrative Tools and then click Dynamics Security Console.

NOTE: The only users that can access the Dynamics Security Console are the users configured as a Security Administrator in the Dynamics Security Console.

3. In the Dynamics Security Console window, expand Microsoft Dynamics Security and then expand Microsoft Dynamics GP Web Services.

4. Click Role Assignments.

5. In the center Role Assignments pane, click the Role column header to sort by Role.

6. Find all the entries for the role and company that you are synchronizing in the in the Security Synchronization Utility.

7. Click to highlight all of the role entries.

8. Under the Actions pane, click Delete to delete the highlighted entries.

9. Run the rule in the Security Synchronization Utility again to add the users to the desired role.

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2622090
Revision : 1
Created on : 1/7/2017
Published on : 6/9/2012
Exists online : False
Views : 89