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A Windows 7-based computer does not enter sleep mode after you play audio files through a USB headset or a USB audio device


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure a Windows 7-based computer to enter sleep mode after the computer is idle for some time.
  • You connect a USB headset or a USB audio device to the computer.
  • You play audio files through the USB headset or the USB audio device by using an application such as Windows Media Player or Windows Internet Explorer.
  • Playback of the audio files finishes.
In this scenario, the computer never enters sleep mode.

Notes
  • The computer enters sleep mode correctly if you close the application that is playing the audio files.
  • When this issue occurs, you receive the following message if you run the powercfg -requests command at the command prompt as an administrator:
    An audio stream is currently in use.

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Cause

This issue occurs because the audio stack does not correctly clear an availability request when audio playback finishes. The expected behavior is that the audio stack sets the availability request when the audio file is being played and clears the availability request when playback stops or is paused.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    1.
    21xxx
    Windows 7 SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Usbaudio.sys6.1.7601.2182980,89630-Sep-201105:54Not applicable
For all supported x64-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Usbaudio.sys6.1.7601.21829109,95230-Sep-201106:09x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size1,628
Date (UTC)30-Sep-2011
Time (UTC)11:52
PlatformNot applicable
File nameX86_wdma_usb.inf_31bf3856ad364e35_6.1.7601.21829_none_6fa317aa2e3e3328.manifest
File versionNot applicable
File size2,271
Date (UTC)30-Sep-2011
Time (UTC)09:00
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_wdma_usb.inf_31bf3856ad364e35_6.1.7601.21829_none_cbc1b32de69ba45e.manifest
File versionNot applicable
File size2,275
Date (UTC)30-Sep-2011
Time (UTC)09:15
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,842
Date (UTC)30-Sep-2011
Time (UTC)11:52
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2619331
Revision : 1
Created on : 1/7/2017
Published on : 12/28/2012
Exists online : False
Views : 187