Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

AD RMS deployment fails in a Windows Server 2008 R2-based domain environment that has SQL Server Pre-Release (codenamed "Denali") installed


View products that this article applies to.

Symptoms

Assume that you try to deploy Active Directory Rights Management Services (AD RMS) in a Windows Server 2008 R2-based domain environment that has SQL Server Pre-Release (codenamed "Denali") installed. In this situation, the deployment fails. Additionally, you receive the following error message:
Attempt to configure Active Directory Rights Management Server failed. The provisioning process failed to create the Configuration database due to the following error from Sql Server: System.Data.SqlClient.SqlException: Could not find stored procedure 'sp_dboption'�.

↑ Back to the top


Cause

This issue occurs because the sp_dboption stored procedure is removed from SQL Server Pre-Release. Therefore, AD RMS installation cannot continue the database operations.

Notesp_dboption is a system stored procedure that can provide displaying and changing database operations. In Windows Server 2008 R2, AD RMS uses this stored procedure to set the proprietaries of rights management databases.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Microsoft.rightsmanagementservices.shared.dll6.1.7600.210552,166,78416-Sep-201105:25x86
Microsoft.rightsmanagementservices.shared.dll6.1.7601.218202,359,29616-Sep-201106:44x86
Microsoft.rightsmanagementservices.configuration.dll6.1.7600.21055745,47216-Sep-201106:55x86
Microsoft.rightsmanagementservices.configuration.dll6.1.7601.21820811,00816-Sep-201106:21x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_802c6071f7e995fe447e3450d2ea5449_31bf3856ad364e35_6.1.7601.21820_none_ba3216b65a1d0782.manifest
File versionNot Applicable
File size1,077
Date (UTC)16-Sep-2011
Time (UTC)18:36
File nameAmd64_d570acb32ecc5456262044f2719442bd_31bf3856ad364e35_6.1.7600.21055_none_a9136331d27118b1.manifest
File versionNot Applicable
File size1,077
Date (UTC)16-Sep-2011
Time (UTC)18:36
File nameMsil_microsoft.rightsman..mentservices.shared_31bf3856ad364e35_6.1.7600.21055_none_68a39af274a3d91e.manifest
File versionNot Applicable
File size2,009
Date (UTC)16-Sep-2011
Time (UTC)08:02
File nameMsil_microsoft.rightsman..mentservices.shared_31bf3856ad364e35_6.1.7601.21820_none_6aa5900e71b63c69.manifest
File versionNot Applicable
File size2,009
Date (UTC)16-Sep-2011
Time (UTC)07:37
File nameMsil_microsoft.rightsman..vices.configuration_31bf3856ad364e35_6.1.7600.21055_none_85b29dd2167b87bb.manifest
File versionNot Applicable
File size1,643
Date (UTC)16-Sep-2011
Time (UTC)07:21
File nameMsil_microsoft.rightsman..vices.configuration_31bf3856ad364e35_6.1.7601.21820_none_87b492ee138deb06.manifest
File versionNot Applicable
File size1,643
Date (UTC)16-Sep-2011
Time (UTC)06:43

↑ Back to the top


Keywords: KB2619256, kbexpertiseinter, kbsurveynew, kbfix, kbHotfixServer, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 2619256
Revision : 1
Created on : 10/12/2011
Published on : 10/12/2011
Exists online : False
Views : 292