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"0xC0000010" error and Http.sys intermittently ends TCP/IP connections in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On�a computer that is running Windows 7 or Windows Server 2008 R2,�the HTTP protocol stack (Http.sys) is used to receive HTTP requests from clients. For example, you have Internet Information Services (IIS) installed, or you have an application that uses the�System.Net.HttpListener�class installed.
  • The computer receives an HTTP request from a client�through the TLS/SSL protocol.�
  • The client sends a TCP-FIN signal to the computer to indicate that it has half-closed the connection on the client side and that there is nothing more to send.
In this scenario, the computer may intermittently send an abortive TCP-RST signal to the client�rather than send any HTTP response. When this issue occurs, an exception may occur on the client side, and it indicates that the server has aborted the connection.

Note If you capture the Event Tracing for Windows (ETW) trace for Http.sys when this issue occurs, you will notice that Http.sys raises the following internal error code before it sends the TCP-RST signal to the client:

0xC0000010

You can see a typical report that resembles the following when you use the Microsoft Network Monitor 3.4 utility to open the ETW trace for Http.sys:

MicrosoftWindowsHttpService MicrosoftWindowsHttpService:Client closed the connection (connection pointer <<address>>). Status of whether closed by TCP Reset: 0 (0x0).

MicrosoftWindowsHttpService MicrosoftWindowsHttpService:SSL connection will be disconnected as initiated by the client.

MicrosoftWindowsHttpService MicrosoftWindowsHttpService:SSL handshake completed with status: 0 (0x0).

MicrosoftWindowsHttpService MicrosoftWindowsHttpService:Decrypted SSL data is available for processing.

MicrosoftWindowsHttpService MicrosoftWindowsHttpService:SSL connection will be disconnected as initiated by the server application. Status: 3221225488 (0xC0000010).

Note�The "0xC0000010" error code translates to STATUS_INVALID_DEVICE_REQUEST and has the following description:
The specified request is not a valid operation for the target device.

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Cause

This issue occurs because Http.sys incorrectly assumes that the client-side has ended the connection. Therefore Http.sys ends the underlying TCP/IP connection.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Http.sys6.1.7600.21057514,04817-Sep-201122:37x86
Http.sys6.1.7601.21822514,04817-Sep-201123:48x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Http.sys6.1.7600.21057750,08017-Sep-201122:57x64
Http.sys6.1.7601.21822753,66417-Sep-201123:47x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Http.sys6.1.7600.210571,442,30417-Sep-201122:18IA-64
Http.sys6.1.7601.218221,442,81617-Sep-201122:16IA-64

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Workaround

To work around the issue, make sure that the client waits for the server's response before it sends a TCP-FIN signal to the server.

Note
�You can work around this issue only on the client side of the connection.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about Microsoft Network Monitor 3.4, visit the following Microsoft website:For more information about how to troubleshoot DHCP clients, visit the following Microsoft website:For more information about the HttpListener class, visit the following Microsoft website:For more information about how to capture ETW traces for Http.sys, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size2,342
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
File nameX86_51b715f06fc03b53f473a2604bf697e3_31bf3856ad364e35_6.1.7600.21057_none_709b99eb1756c28a.manifest
File versionNot applicable
File size692
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
File nameX86_6eaddfb0dcec12fbd0630624dd60d09b_31bf3856ad364e35_6.1.7601.21822_none_116e10e84cc22429.manifest
File versionNot applicable
File size692
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
File nameX86_microsoft-windows-http_31bf3856ad364e35_6.1.7600.21057_none_ad43412f93322633.manifest
File versionNot applicable
File size175,661
Date (UTC)18-Sep-2011
Time (UTC)01:42
PlatformNot applicable
File nameX86_microsoft-windows-http_31bf3856ad364e35_6.1.7601.21822_none_af45364b9044897e.manifest
File versionNot applicable
File size175,661
Date (UTC)18-Sep-2011
Time (UTC)03:12
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_49ed3ca8504b9b9df78857eedf8950d2_31bf3856ad364e35_6.1.7600.21057_none_642ab71f68f29799.manifest
File versionNot applicable
File size696
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
File nameAmd64_69e719483772b5e397a0a6316c8e11bf_31bf3856ad364e35_6.1.7601.21822_none_ec2c0ddd2592c5f0.manifest
File versionNot applicable
File size696
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
File nameAmd64_microsoft-windows-http_31bf3856ad364e35_6.1.7600.21057_none_0961dcb34b8f9769.manifest
File versionNot applicable
File size175,667
Date (UTC)18-Sep-2011
Time (UTC)02:16
PlatformNot applicable
File nameAmd64_microsoft-windows-http_31bf3856ad364e35_6.1.7601.21822_none_0b63d1cf48a1fab4.manifest
File versionNot applicable
File size175,667
Date (UTC)18-Sep-2011
Time (UTC)04:22
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,780
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_0e5e31e1b319fce3fbd44a4bfed8a0fa_31bf3856ad364e35_6.1.7600.21057_none_c6b47b99dbd2943f.manifest
File versionNot applicable
File size694
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
File nameIa64_b312fc1a1a46383c6335b5cb723dd553_31bf3856ad364e35_6.1.7601.21822_none_a62ab32d1fc43ac1.manifest
File versionNot applicable
File size694
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable
File nameIa64_microsoft-windows-http_31bf3856ad364e35_6.1.7600.21057_none_ad44e52593302f2f.manifest
File versionNot applicable
File size175,664
Date (UTC)18-Sep-2011
Time (UTC)02:22
PlatformNot applicable
File nameIa64_microsoft-windows-http_31bf3856ad364e35_6.1.7601.21822_none_af46da419042927a.manifest
File versionNot applicable
File size175,664
Date (UTC)18-Sep-2011
Time (UTC)04:00
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,168
Date (UTC)18-Sep-2011
Time (UTC)07:10
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, KB2618425

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Article Info
Article ID : 2618425
Revision : 2
Created on : 10/24/2011
Published on : 10/24/2011
Exists online : False
Views : 491