Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Group membership is emptied on a Windows Server 2008 R2-based RODC after the group is converted from a universal group into a global domain group or a local domain group


View products that this article applies to.

Symptoms

Consider the following scenario in an Active Directory domain environment:
  • You have a read-only domain controller (RODC) that is running Windows Server 2008 R2.
  • You create a universal group in the domain and then add some members to the group.
  • You manually force replication of the change to the RODC.
  • You convert the universal group into a global domain group or a local domain group.
  • You manually force replication of the change to the RODC again.
In this scenario, the membership of the group is emptied on the RODC.

Notes
  • To manually update changes on the RODC, use the repadmin /replicate command.
  • This issue does not occur on Windows Server 2008 R2-based read/write domain controllers (RWDCs).
  • This issue does not occur if you convert the group back into a universal group and then manually update the change on the RODC.

↑ Back to the top


Cause

This issue occurs because member links are removed incorrectly from the RODC when they are removed from the global catalog (GC) during the conversion from a universal group into a global or local domain group. �

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntdsai.dll6.1.7600.210592,726,40028-Sep-201105:29x64
Ntdsai.dll6.1.7601.218272,726,40028-Sep-201106:36x64

↑ Back to the top


Workaround

To work around this issue, perform a full AD replication on all affected RODCs.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the repadmin /replicate command, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_6c7975cfaa338814beb0353e0354bdaf_31bf3856ad364e35_6.1.7600.21059_none_86783cb411eaf8b7.manifest
File versionNot Applicable
File size716
Date (UTC)28-Sep-2011
Time (UTC)13:47
File nameAmd64_e55c0c3b56239b7240a5191b0da6aaaa_31bf3856ad364e35_6.1.7601.21827_none_ad76ee751034f2e0.manifest
File versionNot Applicable
File size716
Date (UTC)28-Sep-2011
Time (UTC)13:47
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7600.21059_none_4d6922eaebd5a19e.manifest
File versionNot Applicable
File size3,531
Date (UTC)28-Sep-2011
Time (UTC)12:37
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7601.21827_none_4f6e18e4e8e550ee.manifest
File versionNot Applicable
File size3,531
Date (UTC)28-Sep-2011
Time (UTC)07:38

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbHotfixServer, kbfix, kbsurveynew, kbexpertiseinter, KB2616886

↑ Back to the top

Article Info
Article ID : 2616886
Revision : 2
Created on : 12/13/2011
Published on : 12/13/2011
Exists online : False
Views : 298