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You cannot access IRM-protected files that are stored on SharePoint sites by using the WebDAV protocol in Windows Server 2008 R2 or in Windows 7


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 R2 or Windows 7.
  • You try to access some documents that are stored on a Microsoft SharePoint site by using the Web-based Distributed Authoring and Versioning (WebDAV) protocol. The documents are Information Rights Management (IRM)-protected.
In this scenario, you may be unable to open the documents.

The following is a sample scenario:
  • You try to open an IRM-protected Microsoft Office Excel workbook that is stored on a SharePoint site.
  • You are prompted that the document is currently restricted and that Microsoft Office needs to check the licensing and verify your credentials.
  • You click OK, then you receive the following in a pop-up dialog box:
    ERROR: Excel found unreadable content in <file name>. Do you want to recover the contents of this workbook? If you trust the source of the workbook, click Yes.
  • You click Yes, and then Excel suddenly stops and restarts. However, the document is never opened.

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Cause

This issue occurs because the WebDAV client does not open the shared documents by using the correct shared access mode.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxx Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1 . 21xxx Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Webclnt.dll6.1.7600.21053205,31214-Sep-201104:19x86
Webclnt.dll6.1.7601.21818205,31214-Sep-201106:27x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Webclnt.dll6.1.7600.21053258,56014-Sep-201105:23x64
Webclnt.dll6.1.7601.21818258,56014-Sep-201106:37x64
Webclnt.dll6.1.7600.21053205,31214-Sep-201104:19x86
Webclnt.dll6.1.7601.21818205,31214-Sep-201106:27x86

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Workaround

Workaround for Windows 7 and for Windows Server 2008 R2

To work around this problem, follow these steps:
  1. Map a network drive to the SharePoint directory which contains the document.
  2. Open the document from the network drive.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size2,482
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameX86_cb20581b388b210539dbf65b6739807d_31bf3856ad364e35_6.1.7600.21053_none_5b50c24a98fbc2dd.manifest
File versionNot Applicable
File size709
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameX86_e02f55534dc8dc7d09fbb13b16b27e83_31bf3856ad364e35_6.1.7601.21818_none_80e8b01d5a9637ed.manifest
File versionNot Applicable
File size709
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.21053_none_55a40d7b2e0c7740.manifest
File versionNot Applicable
File size2,413
Date (UTC)14-Sep-2011
Time (UTC)04:50
PlatformNot Applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7601.21818_none_57bad5672b0dbc00.manifest
File versionNot Applicable
File size2,413
Date (UTC)14-Sep-2011
Time (UTC)07:04
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_38718c858b6c2fb8e9b35f4a47777c32_31bf3856ad364e35_6.1.7600.21053_none_5d628b3dcc02ca05.manifest
File versionNot Applicable
File size713
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameAmd64_6435bf26753f8be00d9653245a4af062_31bf3856ad364e35_6.1.7601.21818_none_2bbba4cf33e1be60.manifest
File versionNot Applicable
File size713
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameAmd64_bf3cf72190ff4d5adfe11ea31da25798_31bf3856ad364e35_6.1.7601.21818_none_11f8ed44404a8cc6.manifest
File versionNot Applicable
File size1,066
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameAmd64_bfa26e875eaabc1345d6a299472176d8_31bf3856ad364e35_6.1.7600.21053_none_8d34dd222021de13.manifest
File versionNot Applicable
File size1,066
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameAmd64_cb20581b388b210539dbf65b6739807d_31bf3856ad364e35_6.1.7600.21053_none_b76f5dce51593413.manifest
File versionNot Applicable
File size711
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameAmd64_e02f55534dc8dc7d09fbb13b16b27e83_31bf3856ad364e35_6.1.7601.21818_none_dd074ba112f3a923.manifest
File versionNot Applicable
File size711
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameAmd64_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.21053_none_b1c2a8fee669e876.manifest
File versionNot Applicable
File size2,417
Date (UTC)14-Sep-2011
Time (UTC)05:49
PlatformNot Applicable
File nameAmd64_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7601.21818_none_b3d970eae36b2d36.manifest
File versionNot Applicable
File size2,417
Date (UTC)14-Sep-2011
Time (UTC)07:38
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,331
Date (UTC)14-Sep-2011
Time (UTC)10:35
PlatformNot Applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.21053_none_55a40d7b2e0c7740.manifest
File versionNot Applicable
File size2,413
Date (UTC)14-Sep-2011
Time (UTC)04:50
PlatformNot Applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7601.21818_none_57bad5672b0dbc00.manifest
File versionNot Applicable
File size2,413
Date (UTC)14-Sep-2011
Time (UTC)07:04
PlatformNot Applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2614022

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Article Info
Article ID : 2614022
Revision : 1
Created on : 10/12/2011
Published on : 10/12/2011
Exists online : False
Views : 301