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ExOLEDB Provider Does Not Support Authentication


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This article was previously published under Q260771

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Symptoms

When you work with the Exchange OLE DB provider (ExOLEDB), if you try to pass user name and password parameters to open an ActiveX Data Objects (ADO) Connection or Record object, you may receive the following error:
Run-time error '-2147217843 (80040e0d)': Authentication failed"

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Cause

The Exchange OLE DB provider does not support authentication. The calls made when you use this provider run under the security context of the current application.

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Workaround

You may want to use Web Distributed Authoring and Versioning (WebDAV) or Microsoft OLE DB Provider for Internet Publishing (MSDAIPP), which has the ability to authenticate by user name and password.

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More information

The following sample code demonstrates the behavior:
    Dim rec As New ADODB.Record
    Dim strURL As String

    ' This will invoke ExOLEDB by default.
    strURL = "file://./backofficestorage/yourdomain.com/public folders/mypubfolder"
    
    ' Authentication failed here.
    rec.Open strURL, , adModeReadWrite, _
      adCreateCollection Or adCreateOverwrite, , "administrator", "password"
    rec.Close
				

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Keywords: KB260771, kbprb, kbmsg

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Article Info
Article ID : 260771
Revision : 5
Created on : 2/22/2007
Published on : 2/22/2007
Exists online : False
Views : 277