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When using the Microsoft Dynamics CRM client for Outlook 2011, the Quick find in Outlook Client displays unexpected results


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Symptoms

Consider this scenario:
There is a field (attribute) which has display name fully or partially matching with real life name of person. You have added records for this entity with names fully or partially matching with above field display name. When you search in CRM for Outlook using the Quick Find by keywords that fully or partially matches with field display names, search results shows all records.

Example:
  • You have added attributes with following display name on Contact entity:
LAN

IS

IL

SO
  • You add contacts by name:
Alan Jackson

Chris Perry

Gail Erickson

  • Quick find view includes Firstname Lastname in filtering criteria.
  • When you search in Outlook, quick find by keyword Alan, Chris, Jackson or Gail results will show all records instead of records which has the key words included. However, if you search by Al, Chi or Erick search shows accurate results.


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Cause

This issue happens when field names exist within the search terms

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Resolution

Method 1:

Use search syntax like Outlook

Instead of searching for simply Erickson, or Erick, use [Last Name]:Erick* or [Last Name]:Erickson

Instead of searching for simply Alan, use [First Name]:Alan

You can even use syntax like this example to make : [Last Name]:Erick* OR [First Name]:Gail and you would get contacts with last name that contains Erick and contacts with first name that contains Gail.

 

Method 2:

Change display name on the field to be somewhat unique which is not likely to be part of search terms

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More Information

Dynamics CRM 2011 Update Rollup 12 and beyond change this functionality so that the quick find in the CRM client for Outlook and the CRM web client search using similar logic. Update Rollup 12 and beyond will result in the CRM client for Outlook to use the defined quick find view when performing a quick find search rather than searching within the results of the current view.

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2602016
Revision : 1
Created on : 1/7/2017
Published on : 9/6/2013
Exists online : False
Views : 197