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Error Message on the DatabaseMetaData table when you try to export a new or existing Microsoft Dynamics Store Operations database store in Microsoft Dynamics Headquarters Administrator: "Error 0: An error was encountered while exporting data."


Symptoms

When you try to export an existing store from HQ Administrator, you receive the following error message during the export of the DataBaseMetaData table: 

An error was encountered while exporting data. Your store operations database is not complete and may not work correctly. Error 0

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Cause

The DatabaseMetaData table holds encryption key information for the store database only and is not a table in Headquarters.

There may have been scripts/procedure/events ran against your headquarters database which caused the Headquarters database to have the DatabaseMetaData table.

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Resolution

This issue can be resolved by taking the following steps to clear out the DataBaseMetaData table in Headquarters.
  1. Make a backup of your database.

    Note
    See Knowledge Base Article 859729 (https://support.microsoft.com/kb/859729/EN-US/) for information about how to back up a database in Headquarters.
  2. Log into Headquarters Administrator and connect to the headquarters database.
  3. Click Query and then click New to display the New Query window.
  4. In the New Query window, type in the statement below and press the F5 key to execute the query: 
    DELETE DataBaseMetaData
  5. Export the store again.

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More Information

Note This specific error message is a default message that may appear during other processes and table exports of this function. This article relates only to the error message when it appears during the export of the DataBaseMetaData table.

Note See Knowledge Base Article 862150 (https://support.microsoft.com/kb/862150/EN-US/ ) for more information with the "Error 0" error message when you export a new store from Headquarters Administrator.

Also See Knowledge Base Article 862150 (https://mbs2.microsoft.com/Knowledgebase/kbdisplay.aspx?scid=kb,EN-US,862150) for more information with the “Error 0” error message when you export the Items table.

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Keywords: kbmbsmigrate, kbmbspartner, kbsurveynew, kb

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Article Info
Article ID : 2601889
Revision : 1
Created on : 1/7/2017
Published on : 12/21/2011
Exists online : False
Views : 92