Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Incremental changes of free/busy information may not be successful replicated from Exchange Server 2010 to Exchange Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use the Inter-Organization Replication tool (IORepl) to replicate free/busy information in a Microsoft Exchange Server 2003 and Microsoft Exchange Server 2010 coexisting environment.
  • At first, the free/busy information is successfully replicated from the server that is running Exchange Server 2010 to the server that is running Exchange Server 2003.
  • You make some incremental changes of free/busy information on the server that is running Exchange Server 2010.

In this scenario, the synchronization�for the incremental changes of the free/busy information may not be successful from Exchange Server 2010 to Exchange Server 2003. Additionally, you receive the following errors in the replication log:
ERROR: ICS Synchronizer returned error, failed [80004005].


ERROR: Unable to replicate '[publisher name]\SCHEDULE+ FREE BUSY\<IoreplServiceAccountName>' to '[subscriber name]\SCHEDULE+ FREE BUSY'.

↑ Back to the top


Cause

This problem occurs because Exchange Server Information Store Service Provider (Emsmdb32.dll) does not initialize a replication data structure when parsing Incremental Change Synchronization (ICS) data the�Exchange 2010 generates. This causes the IORepl tool not to replicate incremental changes of free/busy information.

↑ Back to the top


Resolution

To resolve this problem, apply this hotfix to the server that is running Exchange Server 2003.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Exchange Server 2003 Service Pack 2 (SP2) installed.

For more information about how to obtain the service pack, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart information

You may have to restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Emsmdb32.dll6.5.7656.5982,01614-Oct-201116:20x86
Exspmsg.dll6.5.7233.418,19208-Aug-200522:02x86


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

For more information about�the Inter-Organization Replication tool, visit the following Microsoft TechNet website:For more information about the Microsoft Exchange Server 2003 version of the Inter-Organizational Replication Tool (IORepl), visit the following Microsoft TechNet website:For more information about Incremental Change Synchronization,�visit the following Microsoft TechNet website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB2601033, kbexpertiseinter, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 2601033
Revision : 1
Created on : 11/11/2011
Published on : 11/11/2011
Exists online : False
Views : 344