Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message on a Windows Server 2003-based computer: "You do not have sufficient access to your computer to connect to the selected printer"


View products that this article applies to.

This article was previously published under Q259937

↑ Back to the top


Symptoms

When you attempt to connect to a printer while you are connected to a Microsoft Windows Server 2003-based or Microsoft Windows 2000-based computer that is running Terminal Services by using the Remote Desktop Protocol (RDP) client, you may receive the following error message:
You do not have sufficient access to your computer to connect to the selected printer.

↑ Back to the top


Cause

The Prevent users from installing printer drivers option is enabled by default in the local security settings.

↑ Back to the top


Resolution

On the server running Terminal Services:
  1. Click Start, point to Programs, click Administrative Tools, and then double-click Local Security Policy.
  2. Double-click Local Policies.
  3. Double-click Security Options.
  4. In the right pane, double-click Prevent users from installing printer drivers.
  5. Click Disabled, and then click OK.
  6. Close the Local Security Settings window.
It may be necessary to reboot the server or to force an immediate policy refresh for the change to take effect. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
227302� Using SECEDIT to force a Group Policy refresh immediately

↑ Back to the top


More information

In a domain environment, administrators may want to change this policy at the domain or organizational unit level, rather than on each server running Terminal Services. This error message does not occur if the server running Terminal Services is a domain controller.

↑ Back to the top


Keywords: KB259937, kbtermserv, kbprint, kbprb, kberrmsg

↑ Back to the top

Article Info
Article ID : 259937
Revision : 8
Created on : 5/21/2007
Published on : 5/21/2007
Exists online : False
Views : 423