Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: You cannot discard the changes after you provide the product key and then click OK when you upgrade to Enterprise edition of Forefront Threat Management Gateway 2010


View products that this article applies to.

Symptoms

Consider the following scenario. You upgrade a server that is running the Standard edition of Microsoft Forefront Threat Management Gateway 2010 to the Enterprise edition. After you type the product key and then click OK, you receive the dialog box that prompts you to apply the changes or discard the changes.

When you click Discard, the dialog box disappears. However, the user interface then displays the version as Enterprise and the Upgrade to Enterprise Edition option is removed.

Note To force the discard of changes, you must exit the TMG Management console.

↑ Back to the top


Cause

This problem occurs because of a problem in the upgrade wizard.

↑ Back to the top


Resolution

To resolve this problem, install the service pack that is described in the following Microsoft Knowledge Base article:
2555840 Description of Service Pack 2 for Microsoft Forefront Threat Management Gateway 2010

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2599065
Revision : 1
Created on : 1/7/2017
Published on : 10/31/2011
Exists online : False
Views : 369