Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ACC2000: "No Current Record" Error with Linked ODBC Tables


View products that this article applies to.

This article was previously published under Q259873

↑ Back to the top


Symptoms

When you use Microsoft Access 2000 to delete or update a record in a linked ODBC table, you receive the following message:
No Current Record
In some cases you also receive the following error message
ODBC Call Failed
followed by a vendor-specific error indicating that the update or delete failed. In either case, you cannot update or delete records.

↑ Back to the top


Cause

In certain situations, Microsoft Jet 4.0 does not properly format the UPDATE or DELETE SQL command, which causes the ODBC driver to return a status code that indicates that no record was modified or deleted. Jet is too restrictive when it applies the Where clause, which results in no record being selected when using certain drivers.

↑ Back to the top


Resolution

To resolve this problem, install the latest Microsoft Jet 4.0 service pack. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
239114 How To: Obtain the Latest Service Pack for the Microsoft Jet 4.0 Database Engine

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB259873, kbhotfixserver, kbqfe, kbfix, kbbug, kberrmsg

↑ Back to the top

Article Info
Article ID : 259873
Revision : 4
Created on : 4/7/2006
Published on : 4/7/2006
Exists online : False
Views : 300