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No search results are returned after you change the name of the current user account in SharePoint Foundation 2010


View products that this article applies to.

Symptoms

Assume that you create a user account that has permissions to view items in a Microsoft SharePoint Foundation 2010 document library. You change the name of the user account, and then you perform a search for items in the document library by using the user account. In this situation, no items are returned.

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Cause

This issue occurs if one of the following conditions is true:
  • SharePoint Foundation 2010 does not store the actual permissions of the current user account.
  • The Site Data web service does not send the UserKey attribute in the User element for user accounts that use claims-based authentication.

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Resolution

To resolve this issue, apply the following update:
2598304 Description of the SharePoint Foundation 2010 hotfix package (Wss-x-none.msp): April 24, 2012

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbqfe, kbsurveynew, kbexpertisebeginner, kb

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Article Info
Article ID : 2598293
Revision : 1
Created on : 1/7/2017
Published on : 6/5/2012
Exists online : False
Views : 290