Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Junk e-mail validation error" error message when you manage the junk email rule for a user’s mailbox in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A user uses Outlook in a Microsoft Exchange Server 2010 environment.
  • The user adds an invalid email address or domain name to the Safe Sender list that is located under Junk E-mail Options. For example, the user adds an email address that is encapsulated in single quotation marks: 'test@domain.com'.
  • You try to manage the junk email rule for the user's mailbox by running the Set-MailboxJunkEmailConfiguration cmdlet with the TrustedSendersAndDomains parameter.
In this scenario, the cmdlet does not run successfully. Additionally, you receive the following error message:
Junk e-mail validation error. Value: email address
+ CategoryInfo : NotSpecified: (0:Int32) [Set-MailboxJunkEmailConfiguration], JunkEmailValidationException
+ FullyQualifiedErrorId : D7CA9FF, Microsoft.Exchange.Management.StoreTasks.SetMailboxJunkEmailConfiguration

↑ Back to the top


Cause

This issue occurs because the Exchange server cannot validate the email addresses in the trusted senders list when the server tries to manage the junk email rules that are stored in the mailbox.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2645995 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 2


↑ Back to the top


Workaround

To work around the issue, the user must remove the invalid entry from the Safe Sender list in Outlook.

↑ Back to the top


More Information

For more information about the Set-MailboxJunkEmailConfiguration cmdlet visit the following Microsoft website:
For more information about the overview of Junk Email Filter, visit the following Microsoft website:
For more information about how to delete junk email rules by using MFCMAPI, click the following article number to view the article in the Microsoft Knowledge Base:

2860406 How to delete junk email rules by using MFCMAPI in an Exchange Server environment
 

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2591572
Revision : 1
Created on : 1/7/2017
Published on : 5/4/2015
Exists online : False
Views : 357