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The BranchCache feature does not work for shared files that are opened in read/write mode in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You enable the BranchCache feature on a branch office network.
  • You open a shared file on the central office network in read/write mode from a computer that is running Windows 7 or Windows Server 2008 R2 on the branch office network.
  • Other users in the branch office network try to open the same shared file.
In this scenario, the BranchCache feature does not work in the branch office network. Other users have to download the shared file from the central office network and then open the downloaded file. This behavior causes poor performance and unnecessary usage of wide area network (WAN) bandwidth.

Additionally, the following events are added to the Microsoft-Windows-BranchCacheSMB/Operational log on the users' computers:

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Cause

This issue occurs because the BranchCache module cannot cache files that are opened in read/write mode.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    16xxx
    Windows 7 and Windows Server 2008 R2RTMGDR
    6.1.760
    0.
    21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    17xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Hashgen.exe6.1.7600.2105716,89618-Sep-201101:39x64
Smbgproxy.dll6.1.7600.1638513,31214-Jul-200901:41x64
Smbhash.exe6.1.7600.2105769,63218-Sep-201101:40x64
Hashgen.exe6.1.7601.2182216,89618-Sep-201102:56x64
Smbgproxy.dll6.1.7601.1751413,82420-Nov-201013:27x64
Smbhash.exe6.1.7601.2182269,63218-Sep-201102:57x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about BranchCache, visit the following Microsoft websites:

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_43fe2fd0dfb24e165510ef0d34fb03db_31bf3856ad364e35_6.1.7600.21057_none_d23e88c090b2a3b4.manifest
File versionNot applicable
File size709
Date (UTC)18-Sep-2011
Time (UTC)22:18
PlatformNot applicable
File nameAmd64_d62ce0380988082906198c4983a687ef_31bf3856ad364e35_6.1.7601.21822_none_4d6b8181bf80d694.manifest
File versionNot applicable
File size709
Date (UTC)18-Sep-2011
Time (UTC)22:18
PlatformNot applicable
File nameAmd64_microsoft-windows-smbhashgeneration_31bf3856ad364e35_6.1.7600.21057_none_4334ff2d15399a09.manifest
File versionNot applicable
File size16,939
Date (UTC)18-Sep-2011
Time (UTC)22:18
PlatformNot applicable
File nameAmd64_microsoft-windows-smbhashgeneration_31bf3856ad364e35_6.1.7601.21822_none_4536f449124bfd54.manifest
File versionNot applicable
File size16,939
Date (UTC)18-Sep-2011
Time (UTC)22:18
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,985
Date (UTC)18-Sep-2011
Time (UTC)22:18
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2591402
Revision : 1
Created on : 1/7/2017
Published on : 12/28/2012
Exists online : False
Views : 266