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The desktop does not load and only displays a black or blue background after you log on to a computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

You may experience the following issues after you log on to a computer that is running Windows 7 or Windows Server 2008 R2:
  • Your desktop does not load. You only see a blue or black background image.
  • Windows Explorer does not run, and you cannot access your data.
  • You receive the following message in a notification balloon:
Failed to connect to a windows service. Windows could not connect to the System Event Notification Service. This problem prevents limited users from logging on to the system. As an administrative user, you can review the System Event Log for details about why the service didn't respond.

When the issue occurs, a service host that contains the following services crashes on system startup:
  • Certificate Propagation
  • Extensible Authentication Protocol
  • Group Policy Client
  • IKE and AuthIP IPsec Keying Modules
  • IP Helper
  • Server
  • Multimedia Class Scheduler
  • User Profile Service
  • Task Scheduler
  • System Event Notification Service
  • Shell Hardware Detection
  • Themes
  • Windows Management Instrumentation
You may experience this issue after you install certain applications, for example Microsoft Application Virtualization Client, on the computer.

Note You have to restart the computer one or more times to recover from this issue.

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Cause

This issue occurs when a new drive is added to the system while background services are still starting. The most common example of this is with Microsoft Application Virtualization Client. When this service starts, it creates a virtual drive. When this drive is created during system startup, the Server service may crash the shared service host process. This process contains other services which are important for completing user logins. When these services fail at startup, a blue or black background image is displayed instead of the user’s desktop.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
 
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2
 

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Version Product SR_Level Service branch
    6.1.760
    0.
    16xxx
    Windows 7 and Windows Server 2008 R2 RTM GDR
    6.1.760
    0.
    21xxx
    Windows 7 and Windows Server 2008 R2 RTM LDR
    6.1.760
    1.
    17xxx
    Windows 7 and Windows Server 2008 R2 SP1 GDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2 SP1 LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File name File version File size Date Time Platform
Smbserver-ppdlic.xrm-ms Not applicable 3,229 17-Aug-2011 04:44 Not applicable
Srvsvc.dll 6.1.7600.21030 168,960 17-Aug-2011 04:28 x86
Sscore.dll 6.1.7600.16385 9,728 14-Jul-2009 01:16 x86
Smbserver-ppdlic.xrm-ms Not applicable 3,229 17-Aug-2011 06:16 Not applicable
Srvsvc.dll 6.1.7601.21792 168,960 17-Aug-2011 06:04 x86
Sscore.dll 6.1.7601.17514 9,728 20-Nov-2010 12:21 x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File name File version File size Date Time Platform
Smbserver-ppdlic.xrm-ms Not applicable 3,229 17-Aug-2011 06:04 Not applicable
Srvsvc.dll 6.1.7600.21030 236,544 17-Aug-2011 05:52 x64
Sscore.dll 6.1.7600.16385 13,312 14-Jul-2009 01:41 x64
Smbserver-ppdlic.xrm-ms Not applicable 3,229 17-Aug-2011 06:32 Not applicable
Srvsvc.dll 6.1.7601.21792 236,544 17-Aug-2011 06:17 x64
Sscore.dll 6.1.7601.17514 13,312 20-Nov-2010 13:27 x64
Sscore.dll 6.1.7600.21030 9,728 17-Aug-2011 04:28 x86
Sscore.dll 6.1.7601.21792 9,728 17-Aug-2011 06:04 x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size2,342
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameX86_0441256e3f4b4496dcf614af002b7a59_31bf3856ad364e35_6.1.7600.21030_none_997f68c804631e97.manifest
File versionNot applicable
File size697
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameX86_8c7d7ab40e1b04e59f8b11e350dcc6d7_31bf3856ad364e35_6.1.7601.21792_none_e30dc8b7dc50866e.manifest
File versionNot applicable
File size697
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameX86_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7600.21030_none_f985cbb16528cd69.manifest
File versionNot applicable
File size51,224
Date (UTC)17-Aug-2011
Time (UTC)17:42
PlatformNot applicable
File nameX86_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7601.21792_none_fb2d71a1627de067.manifest
File versionNot applicable
File size54,097
Date (UTC)17-Aug-2011
Time (UTC)17:42
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_1075ca483d205df4628eec7b575de0d2_31bf3856ad364e35_6.1.7600.21030_none_fce8c3ef03419dd4.manifest
File versionNot applicable
File size1,044
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameAmd64_fa32fbd87643b7475c75a8d3a4e96bdd_31bf3856ad364e35_6.1.7601.21792_none_94f1425210e01b9e.manifest
File versionNot applicable
File size1,044
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameAmd64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7600.21030_none_55a467351d863e9f.manifest
File versionNot applicable
File size51,228
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameAmd64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7601.21792_none_574c0d251adb519d.manifest
File versionNot applicable
File size54,101
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,780
Date (UTC)17-Aug-2011
Time (UTC)17:38
PlatformNot applicable
File nameWow64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7600.21030_none_5ff9118751e7009a.manifest
File versionNot applicable
File size43,342
Date (UTC)17-Aug-2011
Time (UTC)04:50
PlatformNot applicable
File nameWow64_microsoft-windows-smbserver_31bf3856ad364e35_6.1.7601.21792_none_61a0b7774f3c1398.manifest
File versionNot applicable
File size46,215
Date (UTC)17-Aug-2011
Time (UTC)06:24
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2590550
Revision : 2
Created on : 6/21/2017
Published on : 6/21/2017
Exists online : False
Views : 232