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Slow performance or computer stops responding when you try to access data on an IEEE 1394 isochronous streaming device in Windows 7 or in Windows 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You connect an Institute of Electrical and Electronics Engineers (IEEE) 1394 isochronous streaming device to the computer. For example, you connect a camera, an external storage device, or an Apple FireWire drive to the computer.
  • You try to view or access streaming data on the IEEE 1394 isochronous streaming device.
In this scenario, you experience slow performance on the computer or the computer stops responding for 10 minutes or longer. When this issue occurs, you cannot complete any pending tasks. This behavior may also cause video capture and video playback to stop or to drop most video frames.

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Cause

This issue occurs because of an error in the Microsoft IEEE 1394 bus driver. When an IEEE 1394 client driver sends an I/O request block (IRB) with a REQUEST_ISOCH_FREE_BANDWIDTH control code to the IEEE 1394 stack, the I/O request packet (IRP) may return an undocumented Irp->IoStatus.Status = STATUS_ACCESS_DENIED status to the IEEE 1394 stack.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    16xxx
    Windows 7 and Windows Server 2008 R2RTMGDR
    6.1.760
    0.
    21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    17xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTime
1394bus.sys6.1.7600.1638554,78413-Jul-200923:51
1394ohci.sys6.1.7600.16859163,84002-Aug-201103:04
Ohci1394.sys6.1.7600.1638562,46413-Jul-200923:51Not applicable
1394bus.sys6.1.7600.1638554,78413-Jul-200923:51
1394ohci.sys6.1.7600.21021164,86403-Aug-201107:15
Ohci1394.sys6.1.7600.1638562,46413-Jul-200923:51Not applicable
1394bus.sys6.1.7600.1638554,78413-Jul-200923:51
1394ohci.sys6.1.7601.17662164,86403-Aug-201107:38
Ohci1394.sys6.1.7600.1638562,46413-Jul-200923:51Not applicable
1394bus.sys6.1.7600.1638554,78413-Jul-200923:51
1394ohci.sys6.1.7601.21783164,86403-Aug-201108:19
Ohci1394.sys6.1.7600.1638562,46413-Jul-200923:51Not applicable
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
1394bus.sys6.1.7600.1638568,09614-Jul-200900:06
1394ohci.sys6.1.7600.16859228,86402-Aug-201103:39
Ohci1394.sys6.1.7600.1638572,83214-Jul-200900:06
1394bus.sys6.1.7600.1638568,09614-Jul-200900:06
1394ohci.sys6.1.7600.21021230,40003-Aug-201107:56
Ohci1394.sys6.1.7600.1638572,83214-Jul-200900:06
1394bus.sys6.1.7600.1638568,09614-Jul-200900:06
1394ohci.sys6.1.7601.17662229,88803-Aug-201108:20
Ohci1394.sys6.1.7600.1638572,83214-Jul-200900:06
1394bus.sys6.1.7600.1638568,09614-Jul-200900:06
1394ohci.sys6.1.7601.21783229,88803-Aug-201107:45
Ohci1394.sys6.1.7600.1638572,83214-Jul-200900:06

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:
2524249 Video capture and playback stop, or most video frames are dropped, when you connect an IEEE 1394 digital video camera to a computer that is running Windows 7 or Windows Server 2008 R2
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_1394.inf_31bf3856ad364e35_6.1.7600.16859_none_fb2a272c671f8acf.manifest
File versionNot applicable
File size3,572
Date (UTC)03-Aug-2011
Time (UTC)19:40
File nameX86_1394.inf_31bf3856ad364e35_6.1.7600.21021_none_fbcc098d802c3f50.manifest
File versionNot applicable
File size3,572
Date (UTC)03-Aug-2011
Time (UTC)19:40
File nameX86_1394.inf_31bf3856ad364e35_6.1.7601.17662_none_fcfeb2406454614b.manifest
File versionNot applicable
File size3,572
Date (UTC)03-Aug-2011
Time (UTC)19:40
File nameX86_1394.inf_31bf3856ad364e35_6.1.7601.21783_none_fd73af7d7d81524e.manifest
File versionNot applicable
File size3,572
Date (UTC)03-Aug-2011
Time (UTC)19:40
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_1394.inf_31bf3856ad364e35_6.1.7600.16859_none_5748c2b01f7cfc05.manifest
File versionNot applicable
File size3,576
Date (UTC)03-Aug-2011
Time (UTC)19:43
File nameAmd64_1394.inf_31bf3856ad364e35_6.1.7600.21021_none_57eaa5113889b086.manifest
File versionNot applicable
File size3,576
Date (UTC)03-Aug-2011
Time (UTC)19:43
File nameAmd64_1394.inf_31bf3856ad364e35_6.1.7601.17662_none_591d4dc41cb1d281.manifest
File versionNot applicable
File size3,576
Date (UTC)03-Aug-2011
Time (UTC)19:43
File nameAmd64_1394.inf_31bf3856ad364e35_6.1.7601.21783_none_59924b0135dec384.manifest
File versionNot applicable
File size3,576
Date (UTC)03-Aug-2011
Time (UTC)19:43

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2589986
Revision : 1
Created on : 1/7/2017
Published on : 12/27/2012
Exists online : False
Views : 206