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"Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)" error when a client logs off from a Windows Server 2008 R2 Remote Desktop Services session


View products that this article applies to.

Symptoms

When a client logs off from a Remote Desktop Services session on a terminal server that is running Windows Server 2008 R2, you may receive a Stop error message on the terminal server that resembles the following:

Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)

When this issue occurs, remote desktop sessions to the remote desktop server stop responding and then are disconnected. Additionally, the following Error event is logged in the System log of the terminal server:

Log Name: System
Source: Microsoft-Windows-WER-SystemErrorReporting
Date: date & time
Event ID: 1001
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: computer name
Description:
The computer has rebooted from a bugcheck. The bugcheck was: 0x000000ab (parameter 1, parameter 2, parameter 3, parameter 4). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 021411-14234-01.

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Cause

This issue occurs because some objects that the Win32k.sys driver allocates from the session pool are not freed before the session ends. Defective printer drivers may cause this memory leak condition. When this memory leak occurs, the memory manager issues a Stop error to prevent the system from continuing in an unstable state.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.1.7601.218193,140,09615-Sep-201103:43x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_0971789141e7547a9d95eb8353f74448_31bf3856ad364e35_6.1.7601.21819_none_96cef0de5564e41d.manifest
File versionNot applicable
File size698
Date (UTC)15-Sep-2011
Time (UTC)10:37
PlatformNot applicable
File nameAmd64_68b23930019eb8630daefee2956ca951_31bf3856ad364e35_6.1.7601.21819_none_5ac52d0d4d9f272d.manifest
File versionNot applicable
File size1,038
Date (UTC)15-Sep-2011
Time (UTC)10:37
PlatformNot applicable
File nameAmd64_d09c7dd9b793b01dba54ed684c0f3b49_31bf3856ad364e35_6.1.7601.21819_none_f9940e30fc42c48f.manifest
File versionNot applicable
File size698
Date (UTC)15-Sep-2011
Time (UTC)10:37
PlatformNot applicable
File nameAmd64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21819_none_17a82132ca3f6ccc.manifest
File versionNot applicable
File size42,090
Date (UTC)15-Sep-2011
Time (UTC)07:38
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,773
Date (UTC)15-Sep-2011
Time (UTC)10:37
PlatformNot applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21819_none_21fccb84fea02ec7.manifest
File versionNot applicable
File size4,178
Date (UTC)15-Sep-2011
Time (UTC)06:51
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 2585233
Revision : 1
Created on : 1/7/2017
Published on : 10/13/2011
Exists online : False
Views : 223