Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: How to Run Isinteg -t When Isinteg Fails Because of Lack of Disk Space


View products that this article applies to.

This article was previously published under Q258301

↑ Back to the top


Symptoms

When you run the isinteg -fix command and the command fails because of a lack of disk space, you may receive the following error message:
JET Error JET_errDiskFull while opening the IS Databases
When you view the application event log, the following event is displayed:
Event ID: 142
Source: ESE97
Category: Error
Description:
The database disk is full.

↑ Back to the top


Cause

This behavior can occur if there is not enough free space on the drive to create the Refer.mdb file. The Refer.mdb file is a temporary database that is created when you run the Microsoft Exchange Information Store Integrity Checker (Isinteg) utility. Isinteg browses the tables in the information store database, looking for errors. For the cross-reference tables, Isinteg builds a Microsoft Exchange Server database of reference counts (Refer.mdb) before browsing the tables. After traversing all the cross-reference tables, Isinteg compares the counts found to the counts in the reference database. If you run Isinteg with the -fix switch, these counts are updated to their true values as determined by Isinteg.

The default location for the Refer.mdb file is the subdirectory where the information store database is located, which is either the Priv.edb file or the Pub.edb file. If there is not enough room on the drive to build the Refer.mdb file, Isinteg fails, and you receive an "Out Of Disk Space" error message.

↑ Back to the top


Resolution

Exchange Server has an option to run Isinteg and specify a location for the Refer.mdb file. The option is a command-line switch -t. To generate a list of the command-line switches for Isinteg for Exchange Server, go to a command prompt, switch to the Exchsrvr\Bin subdirectory on an Exchange Server computer, and type isinteg without any switches. The command-line switches for Isinteg for Exchange Server 5.5 are listed in the document entitled "Isinteg.rtf" on the Exchange Server 5.5 compact disc.

Both sources give the same syntax for running the command:
isinteg -pri|-pub [-fix]-t refdblocation (default location of the store)
NOTE: The syntax for command-line switches in Isinteg is different from the Eseutil utility; Isinteg uses the dash (-), whereas the Eseutil utility uses the forward slash (/).

When using Isinteg -t, you specify only the location; do not specify the file name:
ISINTEG -FIX -PRI -t d:\ -TEST ALLTESTS
Specifying an alternate location with sufficient space for the Refer.mdb database file should allow the temporary database to be built while Isinteg is running, and allow Isinteg to complete successfully.

↑ Back to the top


More information

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:
258302� XADM: Troubleshooting Refer.mdb File Issues
182081� Description of ISINTEG Utility

↑ Back to the top


Keywords: KB258301, kbprb

↑ Back to the top

Article Info
Article ID : 258301
Revision : 9
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 405