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Windows 7 or Windows Server 2008 R2 stops responding when an application performs many I/O operations to a network share


View products that this article applies to.

Symptoms

Consider the following scenario. You use an application to access a network share from a computer that is running Windows 7 or Windows Server 2008 R2. The application performs many I/O operations to the network share. In this scenario, Windows may stop responding.

If you use the Memory Pool Monitor utility (Poolmon.exe) to troubleshoot this issue, you notice that the values of the AlMs and Powe tags increase and eventually consume all pool resources.

Notes
  • This issue does not occur if you disable the Power service.
  • Windows may recover from this issue if you close the application that is accessing the network.

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Cause

This issue occurs because of a new behavior of the Server Message Block (SMB) mini-redirector (mrxsmb.sys) in Windows 7 and in Windows Server 2008 R2.

In Windows 7 and Windows Server 2008 R2, a power request object is created and then destroyed for every SMB network file operation. When an application performs heavy I/O to the network share, many threads that read or write to the network share create many power request objects. Therefore, the Power service cannot process the power request objects as fast as they are generated.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows 7 and Windows Server 2008 R2RTMGDR
    6.1.760
    0.20xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.17xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTime
Umpo.dll6.1.7600.21015120,32026-Jul-201104:28
Umpo.dll6.1.7601.21778119,80826-Jul-201105:54
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Umpo.dll6.1.7600.21015165,37626-Jul-201105:45
Umpo.dll6.1.7601.21778165,37626-Jul-201105:25

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the Memory Pool Monitor utility, click the following article number to view the article in the Microsoft Knowledge Base:
177415 How to use Memory Pool Monitor (Poolmon.exe) to troubleshoot kernel mode memory leaks
For more information about the Poolmon.exe command-line tool, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_0d7f3cf73cec184de277df0e962bb60a_31bf3856ad364e35_6.1.7600.21015_none_f229d5a439059d6d.manifest
File versionNot applicable
File size708
Date (UTC)26-Jul-2011
Time (UTC)19:37
File nameX86_4dae8d4e1e7bf8855ddda5007bea4dbb_31bf3856ad364e35_6.1.7601.21778_none_db9bfc073764af68.manifest
File versionNot applicable
File size708
Date (UTC)26-Jul-2011
Time (UTC)19:37
File nameX86_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7600.21015_none_5eb60b0cc6abe995.manifest
File versionNot applicable
File size15,950
Date (UTC)26-Jul-2011
Time (UTC)04:57
File nameX86_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7601.21778_none_605eb146c40015ea.manifest
File versionNot applicable
File size15,950
Date (UTC)26-Jul-2011
Time (UTC)06:21
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_2913c45722311c283ce8dc06ddde686d_31bf3856ad364e35_6.1.7601.21778_none_ae0862367ffbc27c.manifest
File versionNot applicable
File size1,066
Date (UTC)26-Jul-2011
Time (UTC)19:37
File nameAmd64_45f57448fc76410cbd624ced737334d1_31bf3856ad364e35_6.1.7600.21015_none_ab888cbb5d6aae35.manifest
File versionNot applicable
File size712
Date (UTC)26-Jul-2011
Time (UTC)19:37
File nameAmd64_8b438b874f595d49613edb174c60e191_31bf3856ad364e35_6.1.7600.21015_none_fb61460498b7373a.manifest
File versionNot applicable
File size1,066
Date (UTC)26-Jul-2011
Time (UTC)19:37
File nameAmd64_93bb5fb604a7506b1f9662fc198c08c4_31bf3856ad364e35_6.1.7601.21778_none_4db29de770d71014.manifest
File versionNot applicable
File size712
Date (UTC)26-Jul-2011
Time (UTC)19:37
File nameAmd64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7600.21015_none_bad4a6907f095acb.manifest
File versionNot applicable
File size15,954
Date (UTC)26-Jul-2011
Time (UTC)06:11
File nameAmd64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7601.21778_none_bc7d4cca7c5d8720.manifest
File versionNot applicable
File size15,954
Date (UTC)26-Jul-2011
Time (UTC)07:02
File nameWow64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7600.21015_none_c52950e2b36a1cc6.manifest
File versionNot applicable
File size12,100
Date (UTC)26-Jul-2011
Time (UTC)04:43
File nameWow64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7601.21778_none_c6d1f71cb0be491b.manifest
File versionNot applicable
File size12,100
Date (UTC)26-Jul-2011
Time (UTC)06:09

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 2582112
Revision : 1
Created on : 1/7/2017
Published on : 9/9/2011
Exists online : False
Views : 262