Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"0x0000008E" Stop error may occur when a user logs off a Windows Server 2003 Terminal Server session from a client computer


View products that this article applies to.

Symptoms

When a user logs off a Windows Server 2003 Terminal Server session from a client computer, the terminal server may restart unexpectedly. Additionally, the user who is logged on to the console of the terminal server receives a Stop error message that resembles the following:

STOP 0x0000008E (parameter1, parameter2, parameter3, parameter4)
KERNEL_MODE_EXCEPTION_NOT_HANDLED


Notes
  • The parameters in this Stop error message may vary, depending on the configuration of the computer.
  • Not all "0x0000008E" Stop errors are caused by this issue.

↑ Back to the top


Cause

This issue occurs because of a race condition in the Win32k.sys module.

↑ Back to the top


Resolution

To resolve this issue, install the following hotfix on the affected computer that is running Windows Server 2003.

Hotfix information

Mainstream support for this product ended on July 13, 2010. A hotfix for this issue exists but is not publicly available. Please review the�Microsoft Support Lifecycle policy.

Extended Support

The Extended Support phase follows Mainstream Support for Business and Developer products.
At the supported service pack level, Extended Support includes:
  • Paid support
  • Security update support at no additional cost
  • Non-security related hotfix support requires a separate Extended Hotfix Support Agreement to be purchased (per-fix fees also apply)
Please note:
  • Microsoft will not accept requests for warranty support, design changes, or new features during the Extended Support phase
  • Extended Support is not available for Consumer, Hardware, or Multimedia products
Please contact Microsoft Support for information on how to obtain the hotfix.

Prerequisites

To apply this hotfix, your must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.48951,871,87212-Aug-201114:18x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.48954,590,08012-Aug-201112:54x64
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.48955,619,20012-Aug-201112:56IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, KB2581128

↑ Back to the top

Article Info
Article ID : 2581128
Revision : 2
Created on : 10/19/2011
Published on : 10/19/2011
Exists online : False
Views : 292