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You receive an error message that states not all the required information is provided with the transaction when you authorize a credit card in Microsoft Dynamics NAV 2009 R2


View products that this article applies to.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

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Symptoms

When you authorize a credit card in Microsoft Dynamics NAV 2009 R2, basic validation information is sent to the Microsoft Dynamics NAV Online service and then forwarded to your payment provider. In this situation, if insufficient payment validation information is submitted for the authorization process, you receive an error message that states not all the required information is provided with the transaction. 
For example, you may receive the following error message:
Authorization transaction with amount of ### failed.
Error Code = 22062;
Message = The transaction was declined by the payment provider.

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Cause

This problem occurs because the validation information that is submitted for the credit card authorization process is insufficient. For some payment providers, you must configure the Microsoft Dynamics Online solution to provide additional validation information. For example, payment providers in the United States require you to specify the credit card holder state.

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More Information

When a credit card is authorized in Microsoft Dynamics NAV 2009 R2, basic validation information is sent to the Microsoft Dynamics Online service and then forwarded to the corresponding payment provider. The basic information includes credit card holder name, address, country, and postal code. However, the validation requirements differ based on the payment provider, the type of the credit card, and the requirements of the credit card–issuing bank.
Before you run the credit card authorization process, make sure that the basic information, such as name, address, postal code, and so on, is entered on the contact card of the credit card holder. For some payment providers, you should configure the Microsoft Dynamics Online solution to provide additional validation information. For example, you must specify the card holder state for payment providers in the United States.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics NAV service pack or the next Microsoft Dynamics NAV version that contains this hotfix.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

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Installation information

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

Note Before you install this hotfix, verify that all Microsoft Navision client users are logged off the system. This includes Microsoft Navision Application Services (NAS) client users. You should be the only client user who is logged on when you implement this hotfix.

To implement this hotfix, you must have a developer license.

We recommend that the user account in the Windows Logins window or in the Database Logins window be assigned the "SUPER" role ID. If the user account cannot be assigned the "SUPER" role ID, you must verify that the user account has the following permissions:
  • The Modify permission for the object that you will be changing.
  • The Execute permission for the System Object ID 5210 object and for the System Object ID 9015 object.


Note You do not have to have rights to the data stores unless you have to perform data repair.

Code changes

Note Always test code fixes in a controlled environment before you apply the fixes to your production computers.
To resolve this problem, follow these steps:
  1. Make sure that the County field (92) exists in the Contact table (5050) and the Contact Card form (5050).
  2. Change the code in the CreateCreditCardObject function in the DO Payment Integration Mgt. codeunit (826) as follows: 
    Existing code
    ...
    CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";
    ...
    Replacement code
    ...
    CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";

    // Add the following line.
    CreditCardInfo.StateOrProvince := Contact.County;
    ...

Prerequisites

You must have Microsoft Dynamics NAV 2009 R2 installed to apply this hotfix.

Removal information

You cannot remove this hotfix.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Keywords: kb, kbqfe, kbmbsquickpub, kbmbspartner, kbmbsmigrate, kbsurveynew, kbnoloc, kbmbscodefix

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Article Info
Article ID : 2580981
Revision : 3
Created on : 1/31/2017
Published on : 1/31/2017
Exists online : False
Views : 181