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The Remote Desktop Gateway service incorrectly blocks a user account whose name contains localized characters in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure a Remote Desktop Web Access (RD Web Access) server on a computer that is running Windows Server 2008 R2.
  • You use a user account to try to connect to a remote desktop server through the RD Web Access server.
  • The user account name contains localized characters.
In this scenario, you cannot connect to the remote desktop server. Additionally, you receive the following error message:
Remote Desktop can’t connect to the remote computer "<name>" for one of the these reasons:

1) Your user account is not authorized to access the RD Gateway "<name>"
2) Your computer is not authorized to access the RD Gateway "<name>"
3) You are using an incompatible authentication method (for example, the RD Gateway might be expecting a smart card but you provided a password)

Contact your network administrator for assistance.

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Cause

This issue occurs because the Remote Desktop Gateway service uses an incorrect method to encode user name characters.

The Remote Desktop Gateway service takes advantage of the Network Policy Server (NPS) service to handle user authentication requests. However, the Remote Desktop Gateway service does not encode user name characters by using the encoding method that the NPS service uses. Therefore, the user cannot connect to the remote desktop server and they receive an error message.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Additionally, the Remote Desktop Gateway role service must be installed on the computer.

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you have to stop the Remote Desktop Gateway service before you install the hotfix to avoid restarting the computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0. 17xxx
    Windows Server 2008 R2RTMGDR
    6.1.760
    0.
    21xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    17xxx
    Windows Server 2008 R2SP1GDR
    6.1.760
    1.
    22xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Aaedge.dll6.1.7600.17045305,66416-Jun-201205:23x64
Aatspp.dll6.1.7600.1704565,02416-Jun-201205:23x64
Tsproxy-edgeadapter-ppdlic.xrm-msNot Applicable3,01816-Jun-201205:39Not Applicable
Aaedge.dll6.1.7600.21238305,66416-Jun-201205:28x64
Aatspp.dll6.1.7600.2123865,02416-Jun-201205:28x64
Tsproxy-edgeadapter-ppdlic.xrm-msNot Applicable3,01816-Jun-201205:47Not Applicable
Aaedge.dll6.1.7601.17866308,73616-Jun-201205:15x64
Aaedge.mofNot Applicable1,26805-Nov-201001:52Not Applicable
Aatspp.dll6.1.7601.1786665,02416-Jun-201205:15x64
Aatspp.mofNot Applicable1,27105-Nov-201001:52Not Applicable
Rap.xmlNot Applicable89505-Nov-201001:52Not Applicable
Tsgateway.xmlNot Applicable42905-Nov-201001:52Not Applicable
Tsproxy-edgeadapter-ppdlic.xrm-msNot Applicable3,01816-Jun-201205:31Not Applicable
Aaedge.dll6.1.7601.22024308,22416-Jun-201205:28x64
Aaedge.mofNot Applicable1,26805-Nov-201001:52Not Applicable
Aatspp.dll6.1.7601.2202465,02416-Jun-201205:28x64
Aatspp.mofNot Applicable1,27105-Nov-201001:52Not Applicable
Rap.xmlNot Applicable89505-Nov-201001:52Not Applicable
Tsgateway.xmlNot Applicable42905-Nov-201001:52Not Applicable
Tsproxy-edgeadapter-ppdlic.xrm-msNot Applicable3,01816-Jun-201205:58Not Applicable

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Workaround

To work around this issue, rename the user account to remove the localized characters. This issue does not occur if all user name characters are from the ASCII character set.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about RD Web Access, visit the following Microsoft TechNet website:

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_153cbfa19d565d1904f821714c5d6e3e_31bf3856ad364e35_6.1.7601.17866_none_df7cab310b5f5c25.manifest
File versionNot Applicable
File size711
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameAmd64_8aa2b9486e7ea13f0cdc1efdca3a3bef_31bf3856ad364e35_6.1.7600.17045_none_5ed2f6f0b97f0b7d.manifest
File versionNot Applicable
File size711
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameAmd64_9218468266efff1e808ef37e470ff71d_31bf3856ad364e35_6.1.7601.22024_none_ceaead278ad767ce.manifest
File versionNot Applicable
File size711
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameAmd64_96451ee4c4ef13188298470d22bf77c4_31bf3856ad364e35_6.1.7600.21238_none_94f230f18e70a7a6.manifest
File versionNot Applicable
File size711
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.17045_none_9a2a8846e64608a1.manifest
File versionNot Applicable
File size99,560
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.21238_none_9ac1f7c1ff58d5a6.manifest
File versionNot Applicable
File size99,560
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7601.17866_none_9bfc6f82e37b8fab.manifest
File versionNot Applicable
File size99,560
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7601.22024_none_9caf238bfc7ac045.manifest
File versionNot Applicable
File size99,560
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameUpdate-bf.mum
File versionNot Applicable
File size1,921
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,959
Date (UTC)16-Jun-2012
Time (UTC)09:33
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2578133
Revision : 1
Created on : 1/7/2017
Published on : 8/15/2012
Exists online : False
Views : 226