Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Kernel sockets leak on a multiprocessor computer that is running Windows Server 2008 R2 or Windows 7


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a multiprocessor computer that is running Windows Server 2008 R2 or Windows 7.
  • You run an application that creates loopback sockets on the computer.
In this scenario, you receive the following error message:
WSAENOBUFS (10055)
An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full.

Specifically, the application may be unable to create new sockets and a "no buffer space available" or "insufficient buffer space" exception occurs on the computer. Additionally, when this issue occurs users cannot remotely connect to the computer until it is restarted.

↑ Back to the top


Cause

This issue occurs because of a race condition in the Ancillary Function Driver for WinSock (Afd.sys) that causes sockets to be leaked. With time, the issue that is described in the "Symptoms" section occurs if all available socket resources are exhausted.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Afd.sys6.1.7600.21004338,94408-Jul-201102:15x86
Afd.sys6.1.7601.21766338,94408-Jul-201103:08x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Afd.sys6.1.7600.21004499,71208-Jul-201102:40x64
Afd.sys6.1.7601.21766499,20008-Jul-201102:26x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Afd.sys6.1.7600.210041,115,64808-Jul-201101:51IA-64
Afd.sys6.1.7601.217661,115,64808-Jul-201101:48IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size2,773
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
File nameX86_1bdfdc89d948a2ccf21f212cf4a8eda8_31bf3856ad364e35_6.1.7601.21766_none_c4e5a1579d609a47.manifest
File versionNot applicable
File size700
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
File nameX86_8dcb7c08fa76a68e2aab7a584b5e2063_31bf3856ad364e35_6.1.7600.21004_none_297d92f6906635f7.manifest
File versionNot applicable
File size700
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
File nameX86_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7600.21004_none_d89d9636d89e80b1.manifest
File versionNot applicable
File size73,506
Date (UTC)08-Jul-2011
Time (UTC)04:51
PlatformNot applicable
File nameX86_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.21766_none_da453c26d5f393af.manifest
File versionNot applicable
File size73,506
Date (UTC)08-Jul-2011
Time (UTC)06:24
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_829b65ae838267d87946615da91666c4_31bf3856ad364e35_6.1.7601.21766_none_a7bc6da53f6c2d32.manifest
File versionNot applicable
File size704
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
File nameAmd64_8b968c874c6483ab6e19b9d62f371f5c_31bf3856ad364e35_6.1.7600.21004_none_c5bf87f159a417d1.manifest
File versionNot applicable
File size704
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
File nameAmd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7600.21004_none_34bc31ba90fbf1e7.manifest
File versionNot applicable
File size73,510
Date (UTC)08-Jul-2011
Time (UTC)05:58
PlatformNot applicable
File nameAmd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.21766_none_3663d7aa8e5104e5.manifest
File versionNot applicable
File size73,510
Date (UTC)08-Jul-2011
Time (UTC)07:07
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,215
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_2590d809562395cf712900bdfc936443_31bf3856ad364e35_6.1.7600.21004_none_89fcc29e342d94bf.manifest
File versionNot applicable
File size702
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
File nameIa64_6bd193795ea82f67491742547fa094fc_31bf3856ad364e35_6.1.7601.21766_none_2602ad309d8d472b.manifest
File versionNot applicable
File size702
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable
File nameIa64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7600.21004_none_d89f3a2cd89c89ad.manifest
File versionNot applicable
File size73,508
Date (UTC)08-Jul-2011
Time (UTC)05:49
PlatformNot applicable
File nameIa64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.21766_none_da46e01cd5f19cab.manifest
File versionNot applicable
File size73,508
Date (UTC)08-Jul-2011
Time (UTC)07:10
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,168
Date (UTC)08-Jul-2011
Time (UTC)19:37
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2577795
Revision : 1
Created on : 1/7/2017
Published on : 7/10/2014
Exists online : False
Views : 320