Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Computer randomly stops responding because of a deadlock situation in Windows Server 2008 R2 or in Windows 7


View products that this article applies to.

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

↑ Back to the top


Symptoms

A computer that is running Windows Server 2008 R2 or Windows 7 randomly stops responding. The issue typically occurs when the memory usage is high and when the memory manager performs frequent paging in and paging out actions.

Note You can use the Memory\Page Faults/sec performance counter to track the paging in and paging out frequency.

↑ Back to the top


Cause

The issue occurs because of a deadlock situation in the Microsoft Filesystem Filter Manager (Fltmgr.sys).

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys6.1.7600.21005198,01609-Jul-201104:33x86
Fltmgr.sys6.1.7601.21767198,01609-Jul-201106:00x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys6.1.7600.21005290,17609-Jul-201105:27x64
Fltmgr.sys6.1.7601.21767289,66409-Jul-201105:29x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys6.1.7600.21005625,53609-Jul-201104:15IA-64
Fltmgr.sys6.1.7601.21767625,53609-Jul-201104:20IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_a74d5cb101d444ebddc845f1e490760f_31bf3856ad364e35_6.1.7600.21005_none_0df4711fe4199404.manifest
File versionNot applicable
File size706
Date (UTC)11-Jul-2011
Time (UTC)18:23
PlatformNot applicable
File nameX86_c3f5b5342f32dca67d37d69e25426bd0_31bf3856ad364e35_6.1.7601.21767_none_0745a6bfbeb6b3f3.manifest
File versionNot applicable
File size706
Date (UTC)11-Jul-2011
Time (UTC)18:23
PlatformNot applicable
File nameX86_microsoft-windows-filtermanager-core_31bf3856ad364e35_6.1.7600.21005_none_11bfc6e0a4fc8c3d.manifest
File versionNot applicable
File size10,677
Date (UTC)09-Jul-2011
Time (UTC)04:58
PlatformNot applicable
File nameX86_microsoft-windows-filtermanager-core_31bf3856ad364e35_6.1.7601.21767_none_13676cd0a2519f3b.manifest
File versionNot applicable
File size10,677
Date (UTC)09-Jul-2011
Time (UTC)06:26
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_3f90d0bae718461ba53c19d3fceb2f64_31bf3856ad364e35_6.1.7601.21767_none_84511c9d7ac09135.manifest
File versionNot applicable
File size710
Date (UTC)11-Jul-2011
Time (UTC)18:23
PlatformNot applicable
File nameAmd64_8de8a5894ffff833624052eec6420192_31bf3856ad364e35_6.1.7600.21005_none_2fdd7a0ae8132815.manifest
File versionNot applicable
File size710
Date (UTC)11-Jul-2011
Time (UTC)18:23
PlatformNot applicable
File nameAmd64_microsoft-windows-filtermanager-core_31bf3856ad364e35_6.1.7600.21005_none_6dde62645d59fd73.manifest
File versionNot applicable
File size10,681
Date (UTC)09-Jul-2011
Time (UTC)05:50
PlatformNot applicable
File nameAmd64_microsoft-windows-filtermanager-core_31bf3856ad364e35_6.1.7601.21767_none_6f8608545aaf1071.manifest
File versionNot applicable
File size10,681
Date (UTC)09-Jul-2011
Time (UTC)07:03
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_8b00c840f42a3e0f1ed21095d00d253e_31bf3856ad364e35_6.1.7601.21767_none_c8b601b8cc2972bd.manifest
File versionNot applicable
File size708
Date (UTC)11-Jul-2011
Time (UTC)18:23
PlatformNot applicable
File nameIa64_c707de4804a8b43b39502b34ea773f33_31bf3856ad364e35_6.1.7600.21005_none_a20438d7df8e9e06.manifest
File versionNot applicable
File size708
Date (UTC)11-Jul-2011
Time (UTC)18:23
PlatformNot applicable
File nameIa64_microsoft-windows-filtermanager-core_31bf3856ad364e35_6.1.7600.21005_none_11c16ad6a4fa9539.manifest
File versionNot applicable
File size10,679
Date (UTC)09-Jul-2011
Time (UTC)05:48
PlatformNot applicable
File nameIa64_microsoft-windows-filtermanager-core_31bf3856ad364e35_6.1.7601.21767_none_136910c6a24fa837.manifest
File versionNot applicable
File size10,679
Date (UTC)09-Jul-2011
Time (UTC)06:57
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbmdd, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2575077
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 296