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A Remote Desktop Services session stops responding during the logoff process in Windows Server 2008 or in Windows Server 2008 R2


View products that this article applies to.

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Symptoms

Consider the following scenario. You install the Remote Desktop Session Host role service on a computer that is running Windows Server 2008 or Windows Server 2008 R2. You try to log off a Remote Desktop Services session on the computer. In this scenario, the Remote Desktop Services session stops responding (hangs). After some time, the computer stops accepting incoming Remote Desktop Protocol (RDP) or Independent Computing Architecture (ICA) connections.

You must turn off and then restart the computer to recover from this issue.

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Cause

This issue occurs because of a deadlock situation in the Csrss.exe process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 Service Pack 2 (SP2) or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.0.6002.228432,053,12027-Apr-201213:21x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.0.6002.228432,768,89627-Apr-201213:56x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.0.6002.228436,660,60827-Apr-201213:05IA-64
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.1.7601.219103,148,28828-Jan-201203:54x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size3,078
Date (UTC)27-Apr-2012
Time (UTC)16:18
PlatformNot Applicable
File nameX86_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22843_none_bb3b5c97b0e85dfd.manifest
File versionNot Applicable
File size6,543
Date (UTC)27-Apr-2012
Time (UTC)14:58
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22843_none_1759f81b6945cf33.manifest
File versionNot Applicable
File size6,559
Date (UTC)27-Apr-2012
Time (UTC)15:44
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,102
Date (UTC)27-Apr-2012
Time (UTC)16:18
PlatformNot Applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22843_none_21aea26d9da6912e.manifest
File versionNot Applicable
File size5,013
Date (UTC)27-Apr-2012
Time (UTC)14:47
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22843_none_bb3d008db0e666f9.manifest
File versionNot Applicable
File size6,551
Date (UTC)27-Apr-2012
Time (UTC)14:24
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,255
Date (UTC)27-Apr-2012
Time (UTC)16:18
PlatformNot Applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22843_none_21aea26d9da6912e.manifest
File versionNot Applicable
File size5,013
Date (UTC)27-Apr-2012
Time (UTC)14:47
PlatformNot Applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_7c70190b2d30483477dc859fbbb71727_31bf3856ad364e35_6.1.7601.21910_none_dc7a38ec0125b72b.manifest
File versionNot applicable
File size698
Date (UTC)30-Jan-2012
Time (UTC)21:41
PlatformNot applicable
File nameAmd64_be58f23e2a54e9197ee01058f08877e6_31bf3856ad364e35_6.1.7601.21910_none_6a3b570b2bd8d1dd.manifest
File versionNot applicable
File size698
Date (UTC)30-Jan-2012
Time (UTC)21:41
PlatformNot applicable
File nameAmd64_c8e4d6ea67826b6d37d57a0e8ff39e28_31bf3856ad364e35_6.1.7601.21910_none_cce27e61bb3ad689.manifest
File versionNot applicable
File size1,038
Date (UTC)30-Jan-2012
Time (UTC)21:41
PlatformNot applicable
File nameAmd64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21910_none_179f207eca4785e4.manifest
File versionNot applicable
File size42,090
Date (UTC)28-Jan-2012
Time (UTC)07:25
PlatformNot applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21910_none_21f3cad0fea847df.manifest
File versionNot applicable
File size4,178
Date (UTC)28-Jan-2012
Time (UTC)06:33
PlatformNot applicable

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Keywords: kb, kbmdd, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2571388
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 195