Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A DTMF-based IVR application that is developed by using Lync Server 2010, UCMA 3.0 Workflow APIs crashes


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You deploy a dual tone multi-frequency (DTMF) based Interactive Voice Response (IVR) application. The application is developed by using Microsoft Lync Server 2010, Unified Communications Managed API 3.0 (UCMA3.0) Workflow Speech controls. 
  • The application contains a SpeechQuestionAnswerActivity and an associated ConsecutiveNoInputsSpeechEventActivity, ConsecutiveNoRecognitionsSpeechEventActivity, SpeechHelpCommandActivity, or SpeechRepeatCommandActivity. These event or command activities contain a StatementActivity or SpeechQuestionAnswerActivity.
  • A user connects to the application, and then the user starts pressing DTMF digits while a question message plays back.
  • The application stops playing the question message and stays silent, and then the user disconnects.
In this scenario, the UCMA 3.0 workflow IVR application crashes. Additionally, you receive the following error message:

System.NullReferenceException was unhandled
Message=Object reference not set to an instance of an object.
Source=System.Workflow.ComponentModel

↑ Back to the top


Cause

This issue occurs because an event or command activity is initiated before the question message has completed playing. Then, internal events occur out of order and cause an unhandled runtime exception in the Windows workflow platform.

↑ Back to the top


Resolution

To resolve this issue, install the following update.

The following files are available for download from the Microsoft Download Center:
Download Download the UcmaWorkflowRuntime.msp package now.

Release Date: April 2012

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.


      

 

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2568557
Revision : 1
Created on : 1/7/2017
Published on : 4/9/2012
Exists online : False
Views : 379