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Virtual machine does not start on a computer that has an AMD CPU that supports the AVX feature and that is running Windows Server 2008 R2


View products that this article applies to.

Symptoms

Issue 1

Consider the following scenario:
  • An AMD CPU that supports the Advanced Vector Extensions (AVX) feature is installed in a computer that is running Windows Server 2008 R2 RTM.

    Note AMD introduced support for the AVX feature in Bulldozer-based multicore processors.
  • You install the Hyper-V server role on the computer.
  • You create a virtual machine on the computer, and then you try to start the virtual machine.
In this scenario, the virtual machine does not start, and you receive an error message that resembles the following:
Virtual machine name could not initialize.

Issue 2

Consider the following scenario:
  • An AMD CPU that supports the AVX feature is installed in a computer that is running Windows Server 2008 R2 Service Pack 1 (SP1).

    Note AMD introduced support for the AVX feature in Bulldozer-based multicore processors.
  • You install the Hyper-V server role on the computer.
  • You create a virtual machine on the computer, and then you try to start the virtual machine.
In this scenario, the virtual machine does not start, and you receive the following error message:
Virtual machine could not start because the hypervisor is not running.
Additionally, the following event is added to the Microsoft-Windows-Hyper-V-Worker-Admin log:

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Cause

Cause of Issue 1

This issue occurs because Windows Server 2008 R2 RTM does not support the AVX feature.

Cause of Issue 2

This issue occurs because Windows Server 2008 R2 SP1 does not support the AVX feature on AMD processors.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows Server 2008 R2RTMGDR
    6.1.760
    0.20xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.17xxx
    Windows Server 2008 R2SP1GDR
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Hvax64.exe6.1.7600.16841634,88023-Jun-201102:44x64
Hvboot.sys6.1.7600.16841117,63223-Jun-201105:29x64
Hvix64.exe6.1.7600.16841687,10423-Jun-201102:44x64
Hvax64.exe6.1.7600.20994635,39223-Jun-201102:46x64
Hvboot.sys6.1.7600.20994117,63223-Jun-201105:31x64
Hvix64.exe6.1.7600.20994687,61623-Jun-201102:46x64
Hvax64.exe6.1.7601.17640610,81623-Jun-201102:39x64
Hvboot.sys6.1.7601.17640118,14423-Jun-201105:42x64
Hvix64.exe6.1.7601.17640652,28823-Jun-201102:39x64
Hvax64.exe6.1.7601.21755607,23223-Jun-201102:25x64
Hvboot.sys6.1.7601.21755118,14423-Jun-201105:21x64
Hvix64.exe6.1.7601.21755652,80023-Jun-201102:25x64

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Workaround

To work around Issue 1, follow these steps:
  1. Start Hyper-V Manager.
  2. Right-click the virtual machine in question, and then click Settings.
  3. Under the Processor configuration for the virtual machine, click to select the Migrate to a physical computer with a different processor version check box, and then click OK.
  4. Start the virtual machine.


To work around Issue 2, run the following command at a command prompt to disable the AVX feature:
bcdedit /set xsavedisable 1

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_8ab218874f211e53241c02d06851224f_31bf3856ad364e35_6.1.7601.17640_none_59dd407a3a1cfd7e.manifest
File versionNot applicable
File size710
Date (UTC)23-Jun-2011
Time (UTC)09:08
PlatformNot applicable
File nameAmd64_bdcbf763b723cc6519cd28f0a4ca3719_31bf3856ad364e35_6.1.7601.21755_none_00998afc887d6290.manifest
File versionNot applicable
File size710
Date (UTC)23-Jun-2011
Time (UTC)09:08
PlatformNot applicable
File nameAmd64_d9491e2eeec8d8c9770e952aa17a4396_31bf3856ad364e35_6.1.7600.20994_none_d0789469181e186b.manifest
File versionNot applicable
File size710
Date (UTC)23-Jun-2011
Time (UTC)09:08
PlatformNot applicable
File nameAmd64_fccc194b9203fad80f07ba95c66b0039_31bf3856ad364e35_6.1.7600.16841_none_117debfd7b5e7416.manifest
File versionNot applicable
File size710
Date (UTC)23-Jun-2011
Time (UTC)09:08
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-drivers-hypervisor_31bf3856ad364e35_6.1.7600.16841_none_8c6d8d0e7f196b01.manifest
File versionNot applicable
File size4,163
Date (UTC)23-Jun-2011
Time (UTC)05:58
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-drivers-hypervisor_31bf3856ad364e35_6.1.7600.20994_none_8cc41b1b985ce285.manifest
File versionNot applicable
File size4,163
Date (UTC)23-Jun-2011
Time (UTC)06:05
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-drivers-hypervisor_31bf3856ad364e35_6.1.7601.17640_none_8e52e9ca7c40bd96.manifest
File versionNot applicable
File size4,163
Date (UTC)23-Jun-2011
Time (UTC)06:09
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-drivers-hypervisor_31bf3856ad364e35_6.1.7601.21755_none_8ed6b81b9561f804.manifest
File versionNot applicable
File size4,163
Date (UTC)23-Jun-2011
Time (UTC)06:53
PlatformNot applicable
File nameUpdate-bf.mum
File versionNot applicable
File size1,915
Date (UTC)23-Jun-2011
Time (UTC)09:08
PlatformNot applicable
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 2568088
Revision : 1
Created on : 1/7/2017
Published on : 9/14/2011
Exists online : False
Views : 133