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Slow performance when you render a report on servers where Symantec Endpoint Protection is installed


Symptoms

When you have Symantec Endpoint Protection installed on the system that is hosting SQL Server Reporting Services, you may notice that it takes a long time to render a report either when displaying a report in a Reportviewer control (in a custom application) or directly through Reporting services (for example using Report Manager).

For additional information on how to determine if you may be running into this issue refer to the More Information section of this document.

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Cause

This is caused by a Network Provider provided with Symantec Endpoint protection called "SnacNp". This can also be caused by other Network Providers that add themselves to the ProviderOrder registry key.

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Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To resolve this issue follow these steps:
  1. Open regedit.
  2. Locate the following key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider
  3. Right click this key and click "Export"
  4. Export and save the file.
  5. Modify the value for the following two keys and remove SnacNp from the value.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder
  6. Restart the Reporting Services service.
  7. Retry your report.
Please Note, this may cause issues with Symantec or any other product that may require a network provider in this registry key. If you modify the key and experience issues restore the registry key from the backup you created earlier and contact the vendor of the application for further assistance.

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More Information

To determine if you may have the issue described in this article follow these steps:
Step 1:
  1. Open SQL Server Management Studio and connect to the SQL Server that houses your ReportServer database.
  2. Open a new query window and select your ReportServer database in the database drop down.
  3. Execute the following query:
    SELECT ReportPath,TimeStart, TimeEnd,(TimeEnd-TimeStart) as TimeDelta, TimeDataRetrieval, TimeProcessing, TimeRendering,
    cast((TimeDataRetrieval+TimeProcessing+TimeRendering) as float)/1000 as TotalRenderTimeInSeconds
    FROM ExecutionLog2 ORDER BY TimeStart DESC
  4. Locate an instance of the report that exhibited slow performance.
  5. If the value for TimeDelta is larger than the value for TotalRenderTime ( >5 seconds longer) then you may be experiencing this issue.
Step 2:
  1. Open regedit.
  2. Locate the following keys:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder
  3. The value of the ProviderOrder key may look similar to the following:
    SnacNp,RDPNP,LanmanWorkstation,webclient
  4. If the key contains SnacNp in front of the defaults of RDPNP,LanmanWorkstation,webclient then you could be running into this issue.
More information about how Network Providers can cause these delays can be found here:

http://technet.microsoft.com/en-us/library/cc732472%28WS.10%29.aspx

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

The information and the solution in this document represents the current view of Microsoft Corporation on these issues as of the date of publication. This solution is available through Microsoft or through a third-party provider. Microsoft does not specifically recommend any third-party provider or third-party solution that this article might describe. There might also be other third-party providers or third-party solutions that this article does not describe. Because Microsoft must respond to changing market conditions, this information should not be interpreted to be a commitment by Microsoft. Microsoft cannot guarantee or endorse the accuracy of any information or of any solution that is presented by Microsoft or by any mentioned third-party provider.

Microsoft makes no warranties and excludes all representations, warranties, and conditions whether express, implied, or statutory. These include but are not limited to representations, warranties, or conditions of title, non-infringement, satisfactory condition, merchantability, and fitness for a particular purpose, with regard to any service, solution, product, or any other materials or information. In no event will Microsoft be liable for any third-party solution that this article mentions.


For additional information consult the following link on Symantec website:

http://www.symantec.com/business/support/index?page=content&id=TECH73013

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Keywords: kb

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Article Info
Article ID : 2565842
Revision : 1
Created on : 1/7/2017
Published on : 7/27/2011
Exists online : False
Views : 287