Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Remote Registry service leaks memory when it handles customized v2 performance counter queries in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create some customized version 2 performance counters on a computer that is running Windows Server 2008 R2 or Windows 7.
  • Some applications or services remotely query these performance counters.
In this scenario, the memory usage of the Remote Registry service on the computer keeps increasing. After a while, the available memory is exhausted on the computer. Therefore, the application or service that runs on the computer crashes or stops responding.

Notes
  • The Remote Registry service (RemoteRegistry) runs in a Svchost.exe process. To obtain the ID of the Svchost.exe process, type the following command at a command prompt, and then press ENTER:
    tasklist -svc
  • If you use Performance Monitor when this issue occurs, Performance Monitor displays information that indicates that the value of the Private Bytes counter for the Svchost.exe process keeps increasing.

↑ Back to the top


Cause

This issue occurs because the Remote Registry service does not release some memory that is allocated for certain threads when these threads end. Therefore, the allocated memory for the Remote Registry service keeps increasing.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Regsvc.dll6.1.7600.21009113,15215-Jul-201107:21x86
Regsvc.dll6.1.7601.21771113,15215-Jul-201105:45x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Regsvc.dll6.1.7600.21009160,76815-Jul-201107:24x64
Regsvc.dll6.1.7601.21771160,76815-Jul-201105:21x64
For all supported IA-64�based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Regsvc.dll6.1.7600.21009332,80015-Jul-201107:15IA-64
Regsvc.dll6.1.7601.21771332,80015-Jul-201104:09IA-64

↑ Back to the top


Workaround

To work around this issue, restart the Remote Registry service.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_0f853e791278eff1ddaa99fee260b16b_31bf3856ad364e35_6.1.7601.21771_none_12dd7a7a59c1bb96.manifest
File versionNot applicable
File size710
Date (UTC)15-Jul-2011
Time (UTC)10:29
PlatformNot applicable
File nameX86_6231d1c22b30ce7523d4c53f65322d12_31bf3856ad364e35_6.1.7600.21009_none_400da4a0e2d92d35.manifest
File versionNot applicable
File size710
Date (UTC)15-Jul-2011
Time (UTC)10:29
PlatformNot applicable
File nameX86_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7600.21009_none_8a205acffda43115.manifest
File versionNot applicable
File size8,057
Date (UTC)15-Jul-2011
Time (UTC)07:57
PlatformNot applicable
File nameX86_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7601.21771_none_8bb32deffb0a629e.manifest
File versionNot applicable
File size8,057
Date (UTC)15-Jul-2011
Time (UTC)06:17
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_47256d0a836c692b6d51f95a547f9af3_31bf3856ad364e35_6.1.7600.21009_none_974e96aea9cfec6d.manifest
File versionNot applicable
File size714
Date (UTC)15-Jul-2011
Time (UTC)10:29
PlatformNot applicable
File nameAmd64_9a45b00709caf7b0fd0a48961082591e_31bf3856ad364e35_6.1.7601.21771_none_927ba3e786ddf163.manifest
File versionNot applicable
File size714
Date (UTC)15-Jul-2011
Time (UTC)10:29
PlatformNot applicable
File nameAmd64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7600.21009_none_e63ef653b601a24b.manifest
File versionNot applicable
File size8,061
Date (UTC)15-Jul-2011
Time (UTC)08:53
PlatformNot applicable
File nameAmd64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7601.21771_none_e7d1c973b367d3d4.manifest
File versionNot applicable
File size8,061
Date (UTC)15-Jul-2011
Time (UTC)07:07
PlatformNot applicable
Additional files for all supported IA-64�based versions of Windows Server 2008 R2
File nameIa64_5c18479b9ab9b174fb685d91d6846bd4_31bf3856ad364e35_6.1.7600.21009_none_981dfa1e2ee7cbee.manifest
File versionNot applicable
File size712
Date (UTC)15-Jul-2011
Time (UTC)10:29
PlatformNot applicable
File nameIa64_a708d4fd2f341933d031da4c4a27a075_31bf3856ad364e35_6.1.7601.21771_none_ff58a6d4b529aecc.manifest
File versionNot applicable
File size712
Date (UTC)15-Jul-2011
Time (UTC)10:29
PlatformNot applicable
File nameIa64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7600.21009_none_8a21fec5fda23a11.manifest
File versionNot applicable
File size8,059
Date (UTC)15-Jul-2011
Time (UTC)08:47
PlatformNot applicable
File nameIa64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7601.21771_none_8bb4d1e5fb086b9a.manifest
File versionNot applicable
File size8,059
Date (UTC)15-Jul-2011
Time (UTC)07:28
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2563399

↑ Back to the top

Article Info
Article ID : 2563399
Revision : 1
Created on : 8/10/2011
Published on : 8/10/2011
Exists online : False
Views : 348