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FIX: "Microsoft Diff and Merge has stopped working" error after you connect to a TFS 2010 SP1 server


Symptoms

Consider the following scenario:
  • You connect to a Microsoft Team Foundation Server (TFS) 2010 Service Pack 1 (SP1) server.
  • You use Microsoft Visual Studio Team Explorer or a command prompt to perform a compare or merge operation on some files.
  • The set of files on which you perform a compare or merge operation includes an empty file.
In this scenario, Team Explorer or the command prompt crashes, and then you receive the following error message:
Microsoft Diff and Merge has stopped working.
Note This issue does not occur if you use the /noprompt option in the tf diff command.

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Cause

This issue occurs because the msdiff!IsGraphemeBreak function crashes when the Diffmerge.exe tool calls the function.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


Prerequisites

To apply this hotfix, you must have Microsoft Visual Studio 2010 Service Pack 1 (SP1) installed.

Restart requirement

You may have to restart the computer after you install this hotfix if the affected files are being used. 

We recommend that you close all instances of Visual Studio before you install this hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Msdiff.dll10.0.40219.328484,68018-Jun-201112:54x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbhotfixdev, kbsurveynew, kb

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Article Info
Article ID : 2561827
Revision : 2
Created on : 9/21/2018
Published on : 9/21/2018
Exists online : False
Views : 131