Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may be unable to access SMB shared files or printers on a remote server in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Assume that you are trying to access shared files or printers that are hosted by a remote server that uses the server message block (SMB) protocol from a computer that is running Windows 7 or Windows Server 2008 R2. In this situation, you may be unable to access the shared files or printers. Additionally, the remote server may become unresponsive to client requests.

Note�This issue does not occur if SMB Version 2 is used.

↑ Back to the top


Cause

This issue occurs when the ephemeral ports in the TCP/IP Port pool are exhausted. This is caused by the SMB virtual circuit (VC) endpoints leaking reference counts.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7600.21020223,23202-Aug-201102:21x86
Mrxsmb10.sys6.1.7601.21782223,74402-Aug-201103:09x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7600.21020287,74402-Aug-201102:49x64
Mrxsmb10.sys6.1.7601.21782288,76802-Aug-201102:32x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7600.21020676,35202-Aug-201101:58IA-64
Mrxsmb10.sys6.1.7601.21782677,37602-Aug-201101:56IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about how to avoid TCP/IP port exhaustion, visit the following Microsoft Developer Network (MSDN) website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_56b81234d516700a718643c69906ee4c_31bf3856ad364e35_6.1.7601.21782_none_d628a08f8446037a.manifest
File versionNot Applicable
File size701
Date (UTC)03-Aug-2011
Time (UTC)00:10
File nameX86_e982549555c7eb1fec61af300799d84c_31bf3856ad364e35_6.1.7600.21020_none_c9e3bfd32cbf313a.manifest
File versionNot Applicable
File size701
Date (UTC)03-Aug-2011
Time (UTC)00:10
File nameX86_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7600.21020_none_89403e2dc5b3e16c.manifest
File versionNot Applicable
File size3,962
Date (UTC)02-Aug-2011
Time (UTC)19:08
File nameX86_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7601.21782_none_8ae7e41dc308f46a.manifest
File versionNot Applicable
File size3,962
Date (UTC)02-Aug-2011
Time (UTC)20:02
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_4f60953a066a641862da498d6efd21a2_31bf3856ad364e35_6.1.7600.21020_none_f5b28043d1ff3b75.manifest
File versionNot Applicable
File size705
Date (UTC)03-Aug-2011
Time (UTC)00:10
File nameAmd64_ab990480ab2c9d7830c754f9a4e668f8_31bf3856ad364e35_6.1.7601.21782_none_251942d26d860d6c.manifest
File versionNot Applicable
File size705
Date (UTC)03-Aug-2011
Time (UTC)00:10
File nameAmd64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7600.21020_none_e55ed9b17e1152a2.manifest
File versionNot Applicable
File size3,966
Date (UTC)02-Aug-2011
Time (UTC)19:20
File nameAmd64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7601.21782_none_e7067fa17b6665a0.manifest
File versionNot Applicable
File size3,966
Date (UTC)02-Aug-2011
Time (UTC)21:03
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_c0d72920d54e51a4ccb8298e32d02766_31bf3856ad364e35_6.1.7601.21782_none_f6ebb2ef2e2fcd7e.manifest
File versionNot Applicable
File size703
Date (UTC)03-Aug-2011
Time (UTC)00:10
File nameIa64_cb107817cf7226845cf376a7a732cbad_31bf3856ad364e35_6.1.7600.21020_none_44b9fd2d09c900f8.manifest
File versionNot Applicable
File size703
Date (UTC)03-Aug-2011
Time (UTC)00:10
File nameIa64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7600.21020_none_8941e223c5b1ea68.manifest
File versionNot Applicable
File size3,964
Date (UTC)02-Aug-2011
Time (UTC)19:12
File nameIa64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7601.21782_none_8ae98813c306fd66.manifest
File versionNot Applicable
File size3,964
Date (UTC)02-Aug-2011
Time (UTC)20:43

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, KB2560452

↑ Back to the top

Article Info
Article ID : 2560452
Revision : 1
Created on : 10/12/2011
Published on : 10/12/2011
Exists online : False
Views : 318