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After exporting Microsoft Dynamics CRM Dynamic Worksheets and/or Dynamic Pivot Tables using Claims Authentication, users do not see the expected data within the Excel worksheet


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Symptoms

After exporting Microsoft Dynamics CRM Dynamic Worksheets and/or Dynamic Pivot Tables using Claims Authentication, users do not see the expected data within the Excel worksheet.

Users may see one of two things within the Excel Worksheet:
1. When using IFD Claims Authentication, users will see the ADFS sign-in page.
2. When using claims authentication, users will get a message stating:
"Script is disabled. Click Submit to continue"

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Cause

Cause 1
Exporting the Dynamic Worksheet and/or Dynamic Pivot Table using Internet Explorer. This issue occurs because Internet Explorer is unable to pass the federation cookie to Excel.

Cause 2
After export the Dynamic Worksheet and/or Dynamic Pivot Table using the Microsoft Dynamics CRM for Microsoft Office Outlook client, users did not refresh the data.

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Resolution

Resolution 1
Dynamic Worksheets and/or Dynamics Pivot Tables require the use of the Excel addin which is part of the Microsoft Dynamics CRM for Microsoft Office Outlook client. You must install the Microsoft Dynamics CRM for Microsoft Office Outlook for the proper version of CRM.

After the Microsoft Dynamics CRM for Microsoft Office Outlook client is installed and configured, the Dynamic Worksheet and/or Dynamic Pivot Table can be exported using the Outlook client, which allows for the transfer of the federation cookie to Excel. 

Resolution 2
After exporting the Dynamic Worksheets and/or Dynamics Pivot Tables refresh the data.
a. Export the Dynamic Worksheets and/or Dynamics Pivot Tables from Microsoft Dynamics CRM.
b. Open up the Dynamic Worksheets and/or Dynamics Pivot Tables with Excel.
c. Within Excel, click on Data tab.
d. Click on Refresh from CRM button.

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More Information

You can workaround the requirement of using the Microsoft Dynamics CRM for Microsoft Office Outlook client by going through the following:
1. Export the Dynamic Worksheets and/or Dynamics Pivot Tables from Microsoft Dynamics CRM.
2.  Open up the Dynamic Worksheets and/or Dynamics Pivot Tables with Excel.
3. After the ADFS sign in page or the "Script is disabled" error shows in the worksheet, click on Data tab.
4. Click on Connections.
5. Within Workbook Connections, click on Properties.
6. Within Connection Properties, click on Definition tab.
7. Click on Edit Query button.
8.  Within the Edit Web Query, window you will need to do one of the following:
     - Using IFD Claims authentication, the Edit Web Query will redirect to ADFS login, enter in the user's credentials and click on Sign In.
     - Using Claims authentication, continue to step 9.
9. After getting the Microsoft Dynamics CRM error, click on OK.
10. Within Edit Web Query, click on Cancel.
11. Within Connection Properties, click on Cancel.
12. Within Workbook Connections, click on Close.
13. Within Excel > Data tab, click on Refresh All.

Note: These steps are required every time you close and re-open the Dynamic Worksheets and/or Dynamics Pivot Tables.

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Article Info
Article ID : 2556284
Revision : 1
Created on : 1/7/2017
Published on : 9/18/2015
Exists online : False
Views : 246