Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Windows Media Services 2008 R2 and Windows Media Services 2008 log a status code of 408 for clients that post large User-Agent strings


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You run an application to play audio or video content on a Windows client.
  • The content is streamed from a Windows Media Services 2008 R2 or Windows Media Services 2008.
  • The cs(User-Agent) field in an HTTP request from the application is greater than 256 bytes.
In this scenario, the Windows Media Services may log a status code of 408 instead of tracking the streamed content.

↑ Back to the top


Cause

The issue occurs because Windows Media Services 2008 R2 and Windows Media Services 2008 limit the length of the cs(User-Agent) field to 256 bytes. If the cs(User-Agent) field in an HTTP request from a client application is greater than 256 bytes, Windows Media Services logs the error that is mentioned in the "Symptoms" section.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 or Windows Server 2008 R2. Additionally, you must have the Streaming Media Services role installed.

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Note If you stop the Windows Media Services service before you install this hotfix, you do not have to restart the computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    1.
    22xxx
    Windows Server 2008RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Wmsserver.dll9.5.6001.229672,909,18420-Sep-201110:16x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Wmsserver.dll9.5.6001.229673,832,32020-Sep-201110:30x64
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    21xxx
    Windows Server 2008 R2RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Wmsserver.dll9.6.7600.210054,031,48809-Jul-201105:25x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size1,887
Date (UTC)20-Sep-2011
Time (UTC)20:02
PlatformNot Applicable
File nameX86_326ea529ec86db07268f7f2dcacdacbb_31bf3856ad364e35_6.0.6001.22967_none_179555e08803b344.manifest
File versionNot Applicable
File size715
Date (UTC)20-Sep-2011
Time (UTC)20:02
PlatformNot Applicable
File nameX86_microsoft-windows-m..ver-server-mainimpl_31bf3856ad364e35_6.0.6001.22967_none_69c275dd7e7929f0.manifest
File versionNot Applicable
File size11,601
Date (UTC)20-Sep-2011
Time (UTC)10:53
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_51d523c6dd82b33fb071a50fae1043d7_31bf3856ad364e35_6.0.6001.22967_none_14515addb88e05f4.manifest
File versionNot Applicable
File size719
Date (UTC)20-Sep-2011
Time (UTC)20:26
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..ver-server-mainimpl_31bf3856ad364e35_6.0.6001.22967_none_c5e1116136d69b26.manifest
File versionNot Applicable
File size11,330
Date (UTC)20-Sep-2011
Time (UTC)11:13
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,899
Date (UTC)20-Sep-2011
Time (UTC)20:26
PlatformNot Applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_microsoft-windows-m..ver-server-mainimpl_31bf3856ad364e35_7.1.7600.21005_none_b7b8131c22a5dca4.manifest
File versionNot applicable
File size4,008
Date (UTC)09-Jul-2011
Time (UTC)05:50

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2556230
Revision : 2
Created on : 9/25/2018
Published on : 9/25/2018
Exists online : False
Views : 204