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An error occurs in Microsoft Dynamics CRM 2011: "The report execution {ID} has expired or cannot be found. rsExecutionNotFound"


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Symptom

Any report run through the Microsoft Dynamics CRM 2011 Data source that is utilizing the Microsoft Dynamics CRM 2011 Data Extensions is showing a RSExectutionNotFound in the CRM User Interface. The SSRS log and platform trace will show the error message below. 

The report execution [id] has expired or cannot be found. (rsExecutionNotFound)

Users may also may see the error below. 

ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerStorageException: An error occurred within the report server database. This may be due to a connection failure, timeout or low disk condition within the database.

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Cause


This can be caused by two timing issues

Cause 1:
The time zone settings on all of the server components did not match. 

Cause 2:
The server system time has a discrepency of 5 minutes or more. 

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Resolution

Both resolutions need to be completed and verified across all servers of a Microsoft Dynamics CRM deployment. This would include the Microsoft SQL server, the SSRS server, as well as all Microsoft Dynamics CRM servers.

Resolution 1:
Correct the time zone settings across the servers so that all of the servers are utilizing the same time zone. 

Resolution 2:
Correct the system time across the servers so that the entire system is within 5 minutes of all servers. 



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Keywords: kb

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Article Info
Article ID : 2550340
Revision : 1
Created on : 1/7/2017
Published on : 11/5/2013
Exists online : False
Views : 235