Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"0x0000007E" Stop error when you access a file on an NTFS volume that enables FSRM quota management in Windows Server 2008


View products that this article applies to.

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

↑ Back to the top


Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008.
  • You enable File Server Resource Manager (FSRM) quota management on an NTFS volume on the computer.
  • You apply NTFS compression to the NTFS volume or to a folder on the NTFS volume. Or, you save sparse files on the NTFS volume.
  • You access a file that uses almost 500 MB of the volume.
In this scenario, the computer may incorrectly restart. When this issue occurs, you receive an error message that resembles the following:
Stop 0x0000007E ( parameter1 , parameter2 , parameter3 , parameter4 )
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
Notes
  • The parameters in this error message may vary, depending on the actual configuration.
  • Not all "0x0000007E" Stop errors are caused by this issue.

↑ Back to the top


Cause

This issue occurs because of an error in the Quota.sys driver.

Under certain conditions, the Quota.sys driver tries to free a memory structure that is Null. Therefore, a Stop error is generated.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
Additionally, the File Server Resource Manager service under the File Services role must be installed.

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    1.
    22xxx
    Windows Server 2008SP1LDR
    6.0.600
    2.
    22xxx
    Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Quota.sys6.0.6001.22925133,52025-May-201117:11x86
Quota.sys6.0.6002.22651133,52025-May-201117:11x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Quota.sys6.0.6001.22925160,65625-May-201117:14x64
Quota.sys6.0.6002.22651160,65625-May-201117:14x64

↑ Back to the top


Workaround

To work around this issue, remove the FSRM quota, or do not compress the files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about a similar issue that occurs in Windows Server 2003 R2, click the following article number to view the article in the Microsoft Knowledge Base:
968451 Stop error message when you enable File Server Resource Manager quota management on an NTFS volume on a Windows Server 2003 R2-based computer: "Stop 0x0000007E"

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size2,220
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameX86_6138abc4745d1408d2f5f4efe1266399_31bf3856ad364e35_6.0.6002.22651_none_8aead9f5536dd985.manifest
File versionNot applicable
File size704
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameX86_9ee13b601f02bb1bbda2eb611a5601b2_31bf3856ad364e35_6.0.6001.22925_none_e7daf5bdaf0e251a.manifest
File versionNot applicable
File size704
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameX86_microsoft-windows-fsrm-quotadriver_31bf3856ad364e35_6.0.6001.22925_none_e7e1f72093e23532.manifest
File versionNot applicable
File size11,233
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameX86_microsoft-windows-fsrm-quotadriver_31bf3856ad364e35_6.0.6002.22651_none_e9a3f81c912478cd.manifest
File versionNot applicable
File size11,233
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_3fe1aa6198f33ff2940ec542a1246786_31bf3856ad364e35_6.0.6002.22651_none_5861950935cf399f.manifest
File versionNot applicable
File size708
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameAmd64_f11668be78d80591ebfee80a6cac43eb_31bf3856ad364e35_6.0.6001.22925_none_a3e3010203802092.manifest
File versionNot applicable
File size708
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameAmd64_microsoft-windows-fsrm-quotadriver_31bf3856ad364e35_6.0.6001.22925_none_440092a44c3fa668.manifest
File versionNot applicable
File size11,241
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameAmd64_microsoft-windows-fsrm-quotadriver_31bf3856ad364e35_6.0.6002.22651_none_45c293a04981ea03.manifest
File versionNot applicable
File size11,241
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,236
Date (UTC)25-May-2011
Time (UTC)17:27
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbmdd, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 2548833
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 137