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CRM Rule Deployment Wizard fails to apply rules to users in Exchange 2010 due to the error: "Failed to access the default store for the user"


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Symptoms

When deploying rules to CRM users with mailboxes on Exchange 2010, utilizing the CRM Rule Deployment Wizard, the following error is displayed: 

“Microsoft.Crm.Tools.ExchangeConnectorDeployment.RuleDeploymentException: Failed to access the default store for the user. ---> System.Runtime.InteropServices.COMException (0x8004010F): Failed to access the default store for the user.”

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Cause

In Exchange 2007, the CRM Rule Deployment Wizard was able to use the System Attendant Mailbox to gain access to user mailboxes to deploy the forwarding rule. However, in Exchange 2010, the System Attendant Mailbox was removed. Thus for Exchange 2010, the CRM Rule Deployment Wizard now uses the Administrator's mailbox to gain access to the user mailboxes to deploy the forwarding rules using MAPI. However, if the account that is running the rule deployment wizard doesn’t have appropriate rights to the Administrator mailbox, the rule deployment wizard will fail. 

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Resolution

The user running the CRM Rule Deployment Wizard must have “Manage Full Access Permission…” on the default domain administrator's mailbox. To check for this setting, perform the following steps:

  1. On the Exchange 2010 mailbox server, click Start, click All Programs, click Microsoft Exchange Server 2010, and select Exchange Management Console
  2. Click Microsoft Exchange On-Premises, click Recipient Configuration, click Mailbox
  3. Right-click the Administrator mailbox and select "Manage Full Access Permission..."
  4. Ensure that the account running the CRM Rule Deployment Wizard is listed in the Manage Full Access Permission dialog box
  5. If the account is not listed, click Add..., search for the user account using the search box, and click OK
  6. Click Manage to complete the permission addition for the user account


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More Information


The CRM Rule Deployment Wizard will look for the Administrator's account in the Organizational Unit where the user mailbox resides. If the account is not found in this OU, the CRM Rule Deployment Wizard will perform a lookup for the "Well known SID" of the domain administrator. This will work unless the domain administrator account was disabled or doesn't have an enabled mailbox. For more information regarding Well Known SID, please see the following Knowledge Base article: http://support.microsoft.com/kb/243330

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2545688
Revision : 1
Created on : 1/7/2017
Published on : 4/20/2012
Exists online : False
Views : 213