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FIX: Java.lang.reflect.InvocationTargetException error when you use Team Explorer Everywhere 2010 SP1 for Eclipse to save or view a work item


Symptoms

Consider the following scenario:
  • You install the following software on a computer:
    • Eclipse 3.5, Eclipse 3.6 or a product that is based on one of these versions. 
    • Microsoft Visual Studio Team Explorer Everywhere 2010 Service Pack 1 (SP1) for Eclipse
    • Windows Internet Explorer 9
  • You use Team Explorer Everywhere 2010 to connect to a Microsoft Team Foundation Server (TFS) server.
  • You try to save or view a work item that contains some HTML controls.
In this scenario, the save or view operation fails. Additionally, you receive the following error message:
Save Failed
Java.lang.reflect.InvocationTargetException

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Cause

This issue occurs because of a change in JavaScript engine that is introduced in Internet Explorer 9. The change conflicts the invoking code in the affected Eclipse versions. This conflict causes a failaure in a feature for the work item that contains a rich text filed control in Team Explorer Everywhere 2010 SP1.Therefore, the error message pops up. 

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Resolution

Hotfix information


The hotfix is available for download from the following Microsoft Download Center website:

Download Download the hotfix package now.
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.


Note To install this hotfix, follow these steps:
  1. Save the Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip file of the hotfix package in a local folder.
  2. Start Eclipse.
  3. On the Help menu, click Install New Software.
  4. Click Add.
  5. Type Local Team Explorer plug-in archive in the Name box, and then click Archive.
  6. Select the Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip file that you saved in a local folder, and then click OK.
  7. In the Install dialog box, click to select the check box that corresponds to Team Explorer Everywhere from the list of features.
  8. Click Next two times.
  9. Accept the Microsoft Software License Terms, and then click Next.
  10. Click Finish.
For more information about how to install Team Foundation Server plug-in and the Command-line Client, download and then view the following Microsoft webpage:

Prerequisites

To install this hotfix, you must have Microsoft Visual Studio Team Explorer Everywhere 2010 Service Pack 1 (SP1) installed on a computer.

Restart information

You must restart Eclipse after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTime
Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zipNot Applicable12,854,61824-May-201107:17

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Workaround

To work around this issue, follow these steps:
  1. Open the Eclipse program folder.
  2. Locate and then open Eclipse.ini in a text editor.

    For example, use Notepad to open the file.
  3. Add the following line at the end of the file:
    -Dcom.microsoft.tfs.client.common.ui.controls.generic.html.htmleditor.disable=
  4. Save the Eclipse.ini file, and then restart Eclipse.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbhotfixdev, kbqfe, kbfix, atdownload, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2540938
Revision : 4
Created on : 9/14/2018
Published on : 9/14/2018
Exists online : False
Views : 92