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The repadmin command keeps running when you try to look up the users who have their passwords stored on the RODC


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You deploy a Windows Server 2008 Read-Only Domain Controller (RODC) in an Active Directory domain environment.
  • You try to run the following command to look up the users who have their passwords stored on the RODC:
    repadmin /prp view RODCName reveal
In this scenario, the repadmim command runs infinitely. Additionally, if you redirect the command output to a file and then stop the command after 20 or 30 seconds, the command reports users in the list circularly.

Notes
  • This issue occurs when there are more than 300 users and computers on the RevealedList.
  • This issue occurs with the version of Repadmin that is included in Windows Server 2008 R2 and in the Remote Server Administration Tools (RSAT) for Windows 7.
  • This issue occurs if the Read/Write Domain Controller (RWDC) that provides the response is running Windows Server 2008 with Service Pack 1 (SP1).

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Cause

This issue occurs because the number of entries in the RevealedList exceeds the range retrieval limit of 1,500. The version of Repadmin that is affected does not handle the range retrieval data correctly. This behavior causes the issue.

Note There are five values that are stored for each (user or computer) account that is represented in the RevealedList. Therefore, the range retrieval limit is exceeded as soon as more than 300 users or computers have their passwords cached.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 with Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 with Service Pack (SP1)
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932

Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system to which each hotfix applies.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    20xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTime
Repadmin.exe6.1.7600.20959251,90404-May-201104:32
Repadmin.exe6.1.7601.21720251,90404-May-201104:25
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Repadmin.exe6.1.7600.20959355,32804-May-201105:14
Repadmin.exe6.1.7601.21720355,84004-May-201105:18

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684

Description of the standard terminology that is used to describe Microsoft software updates

For more information about the Repadmin command, visit the following Microsoft TechNet website:
For more information about how LDAP Ranged Retrieval works, visit the following Microsoft Developer Network (MSDN) website:

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_e70370d27a3c105548c575a753dc8622_31bf3856ad364e35_6.1.7601.21720_none_0e25f983867002e2.manifest
File versionNot applicable
File size739
Date (UTC)04-May-2011
Time (UTC)09:54
File nameX86_fe8c3996d6485f9a87ba802ce9d4f821_31bf3856ad364e35_6.1.7600.20959_none_53cd0bd73a0180ee.manifest
File versionNot applicable
File size739
Date (UTC)04-May-2011
Time (UTC)09:54
File nameX86_microsoft-windows-d..ommandline-repadmin_31bf3856ad364e35_6.1.7600.20959_none_01489448cd70a9d8.manifest
File versionNot applicable
File size2,756
Date (UTC)04-May-2011
Time (UTC)05:09
File nameX86_microsoft-windows-d..ommandline-repadmin_31bf3856ad364e35_6.1.7601.21720_none_03465e78ca86dde2.manifest
File versionNot applicable
File size2,756
Date (UTC)04-May-2011
Time (UTC)05:05
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_57cbfe0913684ec77bd5d13dffa37689_31bf3856ad364e35_6.1.7600.20959_none_e748728e6c8f4df0.manifest
File versionNot applicable
File size743
Date (UTC)04-May-2011
Time (UTC)09:54
File nameAmd64_e210bb5235ef1684541ad7ebd9c1a251_31bf3856ad364e35_6.1.7601.21720_none_28e91358fb96acbc.manifest
File versionNot applicable
File size743
Date (UTC)04-May-2011
Time (UTC)09:54
File nameAmd64_e70370d27a3c105548c575a753dc8622_31bf3856ad364e35_6.1.7601.21720_none_6a4495073ecd7418.manifest
File versionNot applicable
File size741
Date (UTC)04-May-2011
Time (UTC)09:54
File nameAmd64_fe8c3996d6485f9a87ba802ce9d4f821_31bf3856ad364e35_6.1.7600.20959_none_afeba75af25ef224.manifest
File versionNot applicable
File size741
Date (UTC)04-May-2011
Time (UTC)09:54
File nameAmd64_microsoft-windows-d..ommandline-repadmin_31bf3856ad364e35_6.1.7600.20959_none_5d672fcc85ce1b0e.manifest
File versionNot applicable
File size2,760
Date (UTC)04-May-2011
Time (UTC)06:11
File nameAmd64_microsoft-windows-d..ommandline-repadmin_31bf3856ad364e35_6.1.7601.21720_none_5f64f9fc82e44f18.manifest
File versionNot applicable
File size2,760
Date (UTC)04-May-2011
Time (UTC)06:03

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew

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Article Info
Article ID : 2539513
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 225