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Windows Server 2003 does not start after you install security update 979683 (MS10-021)


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2003 Service Pack 2 (SP2) and that has 32 or more processors.
  • You install one or more third-party authentication packages on the computer.
  • You install security update 979683 that is documented in security bulletin MS10-021 on the computer.
In this scenario, Windows does not start, and you receive the following message:
lsass.exe � Operation Failed
The requested operation was unsuccessful.

Note
  • You can start Windows in safe mode when this issue occurs.
  • This issue does not occur on a computer that is running one of the following operating systems:
    • Windows Vista
    • Windows Server 2008
    • Windows 7
    • Windows Server 2008 R2

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Cause

This issue occurs because the number of locked pages that are required by the Lsass.exe process is more than its minimum working set minus a small overhead.

When the Lasss.exe process initializes, it creates some heaps to improve heap handling performance. If the number of processors is 32 or more, and if one or more third-party authentication packages are installed, the Lsass.exe process needs more locked pages. Therefore, the issue that is mentioned in the "Symptoms" section occurs when the minimum working set size is reached.

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Resolution

Note You have to start Windows in safe mode to install the following hotfix package.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.4866818,68810-May-201119:17x86
Updspapi.dll6.3.4.1379,18407-Jul-201015:19x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.4866818,68810-May-201119:17x86
Updspapi.dll6.3.4.1379,18407-Jul-201015:19x86
For all supported IA-64based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.48662,172,41610-May-201116:55IA-64
Updspapi.dll6.3.4.1655,15210-May-201116:57IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information about security update MS10-021, click the following article number to view the article in the Microsoft Knowledge Base:
979683� MS10-021: Vulnerabilities in Windows Kernel could allow elevation of privilege
For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:
960772 � The system may generate Stop error 0x4D when an application uses the VirtualLock function to lock pages in Windows Server 2003 or in Windows XP Professional x64 Edition
For more information about how to process working sets, visit the following MSDN website:
For more information about the�VirtualLock function, visit the following MSDN website:

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Keywords: KB2539164, kbexpertiseinter, kbsurveynew, kbfix, kbhotfixserver, kbqfe

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Article Info
Article ID : 2539164
Revision : 1
Created on : 6/15/2011
Published on : 6/15/2011
Exists online : False
Views : 385