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Unable to re-synchronize contacts from Microsoft Dynamics CRM 2011 to Microsoft Office Outlook after being previously deleted in Outlook


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Symptoms


When Microsoft Dynamics CRM contacts that have been synchronized to Microsoft Office Outlook are deleted directly from Outlook, the contact from Microsoft Dynamics CRM will not re-synchronize back to Outlook

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Cause

This occurs because a modification is made to the OutlookSyncTable and IDMappingTable tables in the local OutlookSyncCache SQL database file that the record has been removed. This imploys the logic that the contact should not be re-synchronized as it has been previously removed. This functionality is by design.

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Resolution

In order to have the Microsoft Dynamics CRM 2011 re-synchronize the previously tracked and deleted Microsoft Office Outlook contacts, the Outlook client needs to be reconfigured. 

Warning: Do not perform these steps if you are in Offline mode as any changes made to the offline data will be lost upon removing the current configuration.

To reconfigure the Microsoft Dynamics CRM 2011 client for Microsoft Office Outlook, complete these steps:

  1. Close Microsoft Office Outlook if it is open.
  2. Click Start, click All Programs, click Microsoft Dynamics CRM 2011, and then click Configuration Wizard.
  3. Select the existing configuration profile, and then click Delete.
  4. Click Add.
  5. Ensure that the CRM URL is listed in the Server URL field, and then click Test Connection.
  6. Enter the credentials that were initially used to configure the Outlook client previously.
  7. Select the appropriate organization in the Organization list.
  8. Enter a display name for the organization in the Display Name field (optional).
  9. Click OK.

With the next synchronization process, the Microsoft Office Outlook client will synchronize contacts from Microsoft Dynamics CRM to Outlook. 

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More Information

The OutlookSyncCache SQL database is located at the file path below based on the operating system

Windows XP: C:/Documents and Settings/

Windows Vista and Windows 7: C:/Users/%userprofile%/AppData/Roaming/Microsoft/MSCRM/Client/OutlookSyncCache.sdf

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Article Info
Article ID : 2538795
Revision : 1
Created on : 1/7/2017
Published on : 3/22/2012
Exists online : False
Views : 299